with S/MIME signed or encrypted messages thunderbird puts localized utf-8 string into 7-bit headers and body

RESOLVED DUPLICATE of bug 723086

Status

RESOLVED DUPLICATE of bug 723086
6 years ago
4 years ago

People

(Reporter: zhalassy, Unassigned)

Tracking

x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Sending S/MIME messages (signed or encrypted) with a localized (non-english) Thunderbird.


Actual results:

When sending S/MIME signed or encrypted messages, Thunderbird puts a localized utf-8 string into the message body, or header. This breaks the rfc and the message might not get delivered.

Signed message (notice the utf-8 string in the body, it should be 7bit as the content-type and content-transfer-encoding doesn't explicitly allow 8bit content, also the Content-Description inner header contains unescaped content):

[...]
Content-Type: multipart/signed; protocol="application/pkcs7-signature"; micalg=sha1; boundary="------------ms090506030700080300010100"

Ez egy kriptográfiai módszerrel aláírt, MIME formátumban levő üzenet.

--------------ms090506030700080300010100
[...]
--------------ms090506030700080300010100
Content-Type: application/pkcs7-signature; name="smime.p7s"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7s"
Content-Description: S/MIME kriptográfiai aláírás

MIAG[...]

Encrypted message:

Again, notice the 8bit content inside the 7bit header.

[...]
Subject: test1
Content-Type: application/pkcs7-mime; name="smime.p7m"
Content-Transfer-Encoding: base64
Content-Disposition: attachment; filename="smime.p7m"
Content-Description: S/MIME titkosított üzenet

MIAG[...]



Expected results:

These texts should get fixed somehow. Like, strip the accents, or don't localize those at all. Some picky MTA might drop the message.

Updated

6 years ago
Component: General → Untriaged

Updated

4 years ago
Component: Untriaged → Security: S/MIME
Product: Thunderbird → MailNews Core
Summary: thunderbird puts localized utf-8 string into 7-bit headers and body → with S/MIME signed or encrypted messages thunderbird puts localized utf-8 string into 7-bit headers and body

Comment 1

4 years ago
Fixed in 31.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723086
You need to log in before you can comment on or make changes to this bug.