amazing drifting context menu

RESOLVED WORKSFORME

Status

()

Core
Widget: Cocoa
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: rillian, Unassigned)

Tracking

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

Today I got an amazing drifting context menu on a video element. It is usually reproducible.

Firefox Nightly 15.0a1 (2012-05-16) on MacOS X 10.7.4.

Steps:

1. Visit https://www.mozilla.org/en-US/webmaker/videos/
2. Click on the video poster to start it playing
3. Right-click on the playing video to bring up the context menu
4. Move the mouse into the context menu
5. Move the mouse out of the context menu without closing it
6. Move the mouse out of the video frame, into the left page margin
7. Move the mouse back into the video frame
8. Context menu starts drifting down and the the right
(Reporter)

Comment 1

6 years ago
Created attachment 626096 [details]
screenshot showing the out of place menu

Note that the menu is actively moving down and to the right from the original click point near the centre of the video, jumping back up in y when it hits the top of the dock.

Comment 2

6 years ago
Amazingness not available on windows :(
(Reporter)

Comment 3

6 years ago
Amazingness is also not available on Linux.

Issue also occurs with today's Nightly 15.0a1 (2012-05-22) on MacOS X.

It's not necessary to start the video playing. The context menu still drifts if it's opened first, but it only moves when the mouse pointer is moving, or very slowly. Different update rate?

Updated

6 years ago
Component: Menus → Widget: Cocoa
Product: Firefox → Core
QA Contact: menus → cocoa
Does this also happen in FF 12, or in one of the FF 13 betas?
(Reporter)

Comment 5

6 years ago
I cannot reproduce on Aurora 14.0a2 (2012-05-22).
(Reporter)

Comment 6

6 years ago
Nor on 12.0.
(Reporter)

Comment 7

6 years ago
I can't reproduced this on the released Firefox 15.0 on MacOS X 10.7.4.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.