The controls should remain visible after seeking if the mouse is over the controls area.

RESOLVED FIXED in mozilla15

Status

()

Toolkit
Video/Audio Controls
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: padenot, Assigned: padenot)

Tracking

unspecified
mozilla15
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

6 years ago
STR : 
- Open an video, or a page containing a <video>, using the default controls ;
- Start playing ;
- Seek somewhere in the video.

Expected result :
- The controls are still shown until the mouse leaves the control area.

Actual results :
- The controls disappear instantly.
(Assignee)

Updated

6 years ago
Assignee: nobody → paul
Blocks: 699719
Summary: Controls should be visible if the mouse is over the controls area. → The controls should remain visible after seeking if the mouse is over the controls area.
This is a feature, not a bug. The controls are *supposed* to autohide if there's no movement, except if the mouse is over the controls area.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
This bug is specifically about leaving the mouse over the controls after finishing seeking.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Oh oops, I misread Paul's comment 0. Carry on.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 4

6 years ago
Created attachment 626282 [details] [diff] [review]
Patch v0 : Don't hide the controls if the mouse is over them.

Somehow, |onMouseInOut| is called when the seekbar is clicked, despite being an event on "mouseout". I don't really know if this is expected, but it hides the controls.

Thus, I'm afraid this patch is fixing the consequences, not the cause.
Attachment #626282 - Flags: review?(jaws)
Attachment #626282 - Flags: review?(jaws) → review+
(Assignee)

Updated

6 years ago
Keywords: checkin-needed
To help people who are landing checkin-needed patches, you should update the commit message to have r=jaws :)
Keywords: checkin-needed
(Assignee)

Comment 6

6 years ago
Created attachment 626533 [details] [diff] [review]
Added reviewer name.

I keep forgeting to do that, fixed.
Attachment #626282 - Attachment is obsolete: true
(Assignee)

Updated

6 years ago
Keywords: checkin-needed

Updated

6 years ago
Duplicate of this bug: 591858
https://hg.mozilla.org/integration/mozilla-inbound/rev/d753a5f4e673
Flags: in-testsuite-
Keywords: checkin-needed
Target Milestone: --- → mozilla15

Comment 9

6 years ago
https://hg.mozilla.org/mozilla-central/rev/d753a5f4e673
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED

Comment 10

3 years ago
This bug seems to have reappeared ( FF 41.0.2 )
Example video:  http://i.imgur.com/OVdKGFt.gifv 

Same as original problem:

- Start playing ;
- Seek somewhere in the video.

Expected result :
- The controls are still shown until the mouse leaves the control area.

Actual results :
- The controls disappear instantly.

Comment 11

3 years ago
Clarification:  The controls disappear on both position seek or resuming from a paused state.  The controls remain visible when using the volume control, pause button, or full-screen button.
First - it's better to file a new bug (perhaps referencing an old bug) for new issues. This bug was fixed 4 years ago, so if further work needs done it should be in a new bug. (Because it makes tracking fixes difficult, and it's often a different issue, anyway.)

In this case, it's an issue with imgur. The site disables the default controls by default, and you have to explicitly enable them to see this at all. But the site seems to remove the |controls| attribute whenever various media events fire. EG, just wait for the video to loop back to the beginning, and this happens.

Not an issue with the Firefox video controls.
You need to log in before you can comment on or make changes to this bug.