Last Comment Bug 757700 - "ABORT: Unknown modification type" with mutation observer, SVG transform
: "ABORT: Unknown modification type" with mutation observer, SVG transform
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86_64 Mac OS X
: -- critical (vote)
: mozilla15
Assigned To: Olli Pettay [:smaug]
:
Mentors:
Depends on:
Blocks: 344905 641821
  Show dependency treegraph
 
Reported: 2012-05-22 19:39 PDT by Jesse Ruderman
Modified: 2012-06-05 09:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (346 bytes, image/svg+xml)
2012-05-22 19:39 PDT, Jesse Ruderman
no flags Details
stack trace (13.14 KB, text/plain)
2012-05-22 19:39 PDT, Jesse Ruderman
no flags Details
patch (3.38 KB, patch)
2012-05-23 00:25 PDT, Olli Pettay [:smaug]
jonas: review+
Details | Diff | Review

Description Jesse Ruderman 2012-05-22 19:39:34 PDT
Created attachment 626292 [details]
testcase

###!!! ABORT: Unknown modification type.: 'aModType == nsIDOMMutationEvent::MODIFICATION', file content/svg/content/src/nsSVGGraphicElement.cpp, line 174

I think the problem is that "modType" is used uninitialized in nsGenericElement::SetAttr.
Comment 1 Jesse Ruderman 2012-05-22 19:39:53 PDT
Created attachment 626293 [details]
stack trace
Comment 3 Jonas Sicking (:sicking) 2012-05-23 17:24:41 PDT
Comment on attachment 626351 [details] [diff] [review]
patch

Review of attachment 626351 [details] [diff] [review]:
-----------------------------------------------------------------

Definitely not related to this bug, but I wonder if it's the right decision to fire mutation observers when an attribute is set to its old value. Last time I measured it was quite common for attributes to be set to a value they already had.

Anyhow, not related to this bug, and if you feel that it's the right thing to fire mutation observers for this situation, then feel free to ignore this comment.
Comment 4 Olli Pettay [:smaug] 2012-05-24 03:21:33 PDT
(In reply to Jonas Sicking (:sicking) from comment #3)
> Comment on attachment 626351 [details] [diff] [review]
> patch
> 
> Review of attachment 626351 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Definitely not related to this bug, but I wonder if it's the right decision
> to fire mutation observers when an attribute is set to its old value. Last
> time I measured it was quite common for attributes to be set to a value they
> already had.
Well, per the current spec, mutationobserver should be fired.
Comment 5 Olli Pettay [:smaug] 2012-05-24 04:50:33 PDT
https://hg.mozilla.org/mozilla-central/rev/0f5089c0daef

Note You need to log in before you can comment on or make changes to this bug.