ftp.mozilla.org should have Mozilla (not Firefox) favicon

VERIFIED FIXED

Status

Infrastructure & Operations
Infrastructure: Other
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: tonymec, Assigned: digi)

Tracking

Details

(URL)

Reproducible: Always

Steps to reproduce:
1. Browse to any page on ftp.mozilla.org (for instance http://ftp.mozilla.org/pub/mozilla.org/thunderbird/ )

Actual results:
The favicon shows the Firefox logo.

Expected results:
For a site which is common to Firefox, Thunderbird, SeaMonkey, Lightning, etc., the favicon should display a generic Mozilla red-dragon favicon.

Additional info:
- This bug might be due to an overreach from bug 542571 or similar.
- See also Bug 682188 comment #26:
> Resolving. If the updating the image on the ftp is still needed we can open
> a new bug.
Status: REOPENED → RESOLVED
Resolution: --- → FIXED
(In reply to Tony Mechelynck [:tonymec] from comment #0)
> Additional info:
> - This bug might be due to an overreach from bug 542571 or similar.

This was clearly broken by the "one mozilla" merge clobbering http://www.mozilla.org/favicon.ico nearly a year ago (because the mozilla.com people were unwilling to fix all of their pages to use a <link> element to use the migrated http://www.mozilla.com/favicon.ico), thereby breaking anything that also referred to http://www.mozilla.org/favicon.ico, like ftp:

(In reply to Tony Mechelynck [:tonymec] from bug 682188 comment #19)
> Currently, when I browse to http://ftp.mozilla.org/favicon.ico I get a
> redirect: my URL bar changes to http://www.mozilla.org/favicon.ico and I get
> the Firefox icon. I suppose that redirect would have to go.

(In reply to Andrei Hajdukewycz [:sancus] from bug 682188comment #20)
> Or just change the redirect to http://www.mozilla.org/org/favicon.ico

justdave, does this bug belong in ServerOps somewhere?  And/or do you know can reconfigure the redirect on ftp.m.o's http side?
Blocks: 610724
Assignee: nobody → server-ops-devservices
Component: other.mozilla.org → Server Operations: Developer Services
Product: Websites → mozilla.org
QA Contact: other-mozilla-org → shyam
Version: unspecified → other
Dev Services doesn't handle FTP, that's Product Delivery..therefore re-assigning to Infrastructure.
Assignee: server-ops-devservices → server-ops-infra
Component: Server Operations: Developer Services → Server Operations: Infrastructure
QA Contact: shyam → jdow

Updated

6 years ago
Assignee: server-ops-infra → bhourigan
(Assignee)

Comment 3

6 years ago
Changed favicon.ico to http://www.mozilla.org/media/img/favicon.png
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
All ftp.mozilla.org pages I tried now display the "red dragon" favicon.
=> VERIFIED
Status: RESOLVED → VERIFIED
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.