Bizarre error submitting bug

RESOLVED WORKSFORME

Status

()

bugzilla.mozilla.org
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: philor, Unassigned)

Tracking

Production
x86
Mac OS X

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 626348 [details]
screenshot

Submitted a bug, pretty close to right at midnight, and post_bug.cgi gave me the html-as-text/plain error message in the screenshot.
[Tue May 22 23:59:54 2012] [error] DBD::mysql::st execute failed: Deadlock found when trying to get lock; try restarting transaction [for Statement "UPDATE bugs SET delta_ts = ? WHERE bug_id = ?" with ParamValues: 0='2012-05-22 23:59:54', 1=307181] at /Bugzilla/Bug.pm line 669. [#1337756394.8244]
[Tue May 22 23:59:55 2012] [error] [client 10.8.82.212] malformed header from script. Bad header=<!DOCTYPE html PUBLIC "-//W3C/: post_bug.cgi, referer: https://bugzilla.mozilla.org/enter_bug.cgi?product=Core
[Tue May 22 23:59:55 2012] [warn] /post_bug.cgi did not send an HTTP header

a few things going on here.

the crux of the problem is the database deadlock.

the [#1337756394.8244] at the end of the message is an indication that it was sent to arecibo for logging, however it never made it.

then there's the missing content-type header.

i suspect the end result, with a text/plain content-type, is the result of the error handler trying its best to recover from a weird situation.


uh, not really sure what to do here; so i'm going to put it down to a glitch in the matrix.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.