java.lang.IllegalStateException: The content of the adapter has changed but ListView did not receive a notification. Make sure the content of your adapter is not modified from a background thread, but only from the UI thread

RESOLVED DUPLICATE of bug 732901

Status

()

--
critical
RESOLVED DUPLICATE of bug 732901
6 years ago
6 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash})

14 Branch
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature)

(Reporter)

Description

6 years ago
There are 8 crashes in 14.b2, including this one: bp-17ab8ccf-a966-42b5-9828-dd9872120523.

java.lang.IllegalStateException: The content of the adapter has changed but ListView did not receive a notification. Make sure the content of your adapter is not modified from a background thread, but only from the UI thread. [in ListView(2131492930, class android.widget.ListView) with Adapter(class org.mozilla.gecko.TabsTray$TabsAdapter)], item count:5, adapter count:3
	at android.widget.ListView.layoutChildren(ListView.java:1558)
	at android.widget.ListView.commonKey(ListView.java:2103)
	at android.widget.ListView.onKeyDown(ListView.java:2084)
	at android.view.KeyEvent.dispatch(KeyEvent.java:1503)
	at android.view.View.dispatchKeyEvent(View.java:3902)
	at android.view.ViewGroup.dispatchKeyEvent(ViewGroup.java:809)
	at android.widget.ListView.dispatchKeyEvent(ListView.java:2069)
	at android.view.ViewGroup.dispatchKeyEvent(ViewGroup.java:811)
	at android.view.ViewGroup.dispatchKeyEvent(ViewGroup.java:811)
	at android.view.ViewGroup.dispatchKeyEvent(ViewGroup.java:811)
	at android.view.ViewGroup.dispatchKeyEvent(ViewGroup.java:811)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.superDispatchKeyEvent(PhoneWindow.java:1796)
	at com.android.internal.policy.impl.PhoneWindow.superDispatchKeyEvent(PhoneWindow.java:1152)
	at android.app.Activity.dispatchKeyEvent(Activity.java:2176)
	at com.android.internal.policy.impl.PhoneWindow$DecorView.dispatchKeyEvent(PhoneWindow.java:1763)
	at android.view.ViewRoot.deliverKeyEventToViewHierarchy(ViewRoot.java:2728)
	at android.view.ViewRoot.handleFinishedEvent(ViewRoot.java:2700)
	at android.view.ViewRoot.handleMessage(ViewRoot.java:1981)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:150)
	at android.app.ActivityThread.main(ActivityThread.java:4333)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:507)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:849)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:607)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.IllegalStateException%3A+The+content+of+the+adapter+has+changed+but+ListView+did+not+receive+a+notification.+Make+sure+the+content+of+your+adapter+is+not+modified+from+a+background+thread%2C+but+only+from+the+UI+thread.+[in+ListView%282131492930%2C+c...

Comment 1

6 years ago
This sounds like it will be fixed by bug 732901. The patches in that bug didn't make it into 14.0b2, so we should just reopen this if we see this again in 14.0b3.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 732901
You need to log in before you can comment on or make changes to this bug.