Closed Bug 757869 Opened 10 years ago Closed 7 years ago

Can't setup YouSendit FileLink account

Categories

(Thunderbird :: FileLink, defect)

x86
macOS
defect
Not set
critical

Tracking

(thunderbird13-, thunderbird14-, thunderbird15+)

RESOLVED WONTFIX
Tracking Status
thunderbird13 - ---
thunderbird14 - ---
thunderbird15 + ---

People

(Reporter: davida, Assigned: mconley)

References

()

Details

(Whiteboard: [gs])

Attachments

(1 file)

I tried the filelink thing, got stuck, w/ an error in console.

- attach 1.1m file
- notice infobar, click on learn more... button
- read that, go back to email, click on whatever theright button is
- pick yousendit, click on create account
- go through yousendit flow to create account, confirm, etc.
- go back to email, type in accountname, click on Set up Account -> nothing happens

Error console shows: 

Timestamp: May 23 '12 9:03:40 AM
Error: TypeError: this._accountType is null
Source File: chrome://messenger/content/cloudfile/addAccountDialog.js
Line: 198
Weird -- hit cancel and it asked me for my pw!

but the dialog doesn't seem to like my pw, and can't actually escape this dialog -- escape keeps bringing it back.

Using dailybird.  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:14.0) Gecko/20120517 Thunderbird/14.0a2

On trying again, get a weird dialog
Attached image weird screenshot
feels pretty important, suggest someone try to repro.
Severity: normal → critical
Trying to reproduce now.
Assignee: nobody → mconley
more errors:

Timestamp: May 23 '12 9:13:08 AM
Error: [Exception... "Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIPrefBranch.getCharPref]"  nsresult: "0x8000ffff (NS_ERROR_UNEXPECTED)"  location: "JS frame :: resource:///modules/cloudFileAccounts.js :: <TOP_LEVEL> :: line 232"  data: no]
Source File: resource:///modules/cloudFileAccounts.js
Line: 235
Unable to reproduce using a fresh profile.

David - if you open up TB's config editor, what prefs are set under mail.cloud_files? Are you able to post a screenshot of those?
Ludo:

Are you able to reproduce this one?

-Mike
I am experiencing something similar on 757894. 

David, when you clicked on 'create an account', did you go through the YSI registration in Firefox session or within TB? It is supposed to be handled in a TB tab, that would explain...
(In reply to Jb Piacentino from comment #8)
> I am experiencing something similar on 757894. 
> 
> David, when you clicked on 'create an account', did you go through the YSI
> registration in Firefox session or within TB? It is supposed to be handled
> in a TB tab, that would explain...

Hm - account registration is not something that TB listens for or cares about. As the code stands, it should not make a difference whether or not registration occurs in TB, FF, or on a completely separate computer.
Having said that, Jb - did you get into a state where you also could not add your YouSendIt account properly?
Configuration went smoothly on my side... weird
So just tried the complete process and it worked very well for me.
I just tried this on TB 13 Beta 3 and the yousendit registration process opened in a Firefox tab not a Thunderbird tab (if it's supposed to happen in TB tab instead of a FF tab, let me know and I'll open a separate bug)
Not tracking as we can't find any steps to reproduce.
I had a similar issue on setting up YouSendIt account and found others on forums. On password entry it returned an error "error occurred while setting up account". On a hunch I changed my password to eliminate the extended ASCII character and this resolved the issue.

Using TB13 on Ubuntu 12.04/Gnome3
So according to this GS article [1], YouSendIt is having difficulty handling passwords with certain characters in it. They're currently working on a fix. The current workaround is to temporarily change your password to not include special characters [2] until the fix is released.

[1]  https://getsatisfaction.com/mozilla_messaging/topics/cannot_set_up_yousendit_in_thunderbird_13_0_1
[2]  Although it's still not clear to me what special characters are working and which ones are not...
Status: NEW → ASSIGNED
Maxim, are you aware of this password bug?
Tracking due to the password issue.
Maxim, can you take a look at this please and advise. Thanks.
Mike, Maxim, any chance of a status update?
I'll send mail to Maxim.
I setup the normal 'cypherpunks' 'writecode' combo for use with TorBirdy - to ensure that FileLinks don't leak or break TorBirdy/Thunderbird. Thunderbird reports "An error occurred while setting up the account!"
Whiteboard: [gs]
Component: General → FileLink
(In reply to Mike Conley (:mconley) - Needinfo me! from comment #21)
> I'll send mail to Maxim.

issue now moot?
Flags: needinfo?(mconley)
Issue now moot.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mconley)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.