libEGL error 'call to OpenGL ES API with no current context (logged once per thread)'

RESOLVED FIXED in Firefox 14

Status

()

Firefox for Android
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: BenWa, Assigned: BenWa)

Tracking

unspecified
Firefox 15
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed, blocking-fennec1.0 +)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
While running on the adreno I get these errors on startup:

E/libEGL  ( 5081): call to OpenGL ES API with no current context (logged once per thread)
E/libEGL  ( 5081): call to OpenGL ES API with no current context (logged once per thread)
E/libEGL  ( 5081): call to OpenGL ES API with no current context (logged once per thread)
E/libEGL  ( 5081): call to OpenGL ES API with no current context (logged once per thread)
(repeat a dozen times)

These error are from GLController.initEGL()
(Assignee)

Comment 1

5 years ago
Created attachment 626562 [details] [diff] [review]
patch

We can't init there since we don't have a current surface.

The init code will get called part of GeckoLayerClient.createFrame().
Assignee: nobody → bgirard
Status: NEW → ASSIGNED
Attachment #626562 - Flags: review?(joe)
(Assignee)

Updated

5 years ago
blocking-fennec1.0: --- → ?
Attachment #626562 - Flags: review?(joe) → review+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/5f82df6b980e
Target Milestone: --- → Firefox 15
(Assignee)

Comment 3

5 years ago
I want more testing on trunk before uplifting.

This error is causing bad log errors on Adreno and is generally wrong everywhere.

Comment 4

5 years ago
Sorry, believed to be the cause of reftest failures, so backed out.

eg https://tbpl.mozilla.org/php/getParsedLog.php?id=12029801&tree=Mozilla-Inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/ac4670bbfb47
blocking-fennec1.0: ? → -
https://hg.mozilla.org/mozilla-central/rev/5f82df6b980e
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
I lied

https://hg.mozilla.org/mozilla-central/rev/ac4670bbfb47
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

5 years ago
Created attachment 628419 [details] [diff] [review]
patch v2 (fix reftest failures)

Try submission of an equivalent patch:
https://tbpl.mozilla.org/?tree=Try&rev=1227359c8ae9
Attachment #626562 - Attachment is obsolete: true
Attachment #628419 - Flags: review?(joe)
(Assignee)

Updated

5 years ago
Attachment #628419 - Flags: review?(joe) → review?(jmuizelaar)
Attachment #628419 - Flags: review?(jmuizelaar) → review+
Blocks: 758635
Blocks: 760226
(Assignee)

Comment 8

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/49c4516cea29
https://hg.mozilla.org/mozilla-central/rev/49c4516cea29
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 628419 [details] [diff] [review]
patch v2 (fix reftest failures)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): None
User impact if declined: Warnings, and possible GL crashes, a bunch of other bugs depend on this especially bug 754257 which is a fennec blocker
Testing completed (on m-c, etc.): Has been on m-c for a couple of days
Risk to taking this patch (and alternatives if risky): Mobile only, 
String or UUID changes made by this patch: None
Attachment #628419 - Flags: approval-mozilla-aurora?
(In reply to Jeff Muizelaar [:jrmuizel] from comment #10)
> Risk to taking this patch (and alternatives if risky): Mobile only, 

What's the risk to mobile? Since this isn't a release blocker, we want to make sure it carries no additional risk if approved.

Updated

5 years ago
Attachment #628419 - Flags: approval-mozilla-aurora? → approval-mozilla-beta?
(In reply to Alex Keybl [:akeybl] from comment #11)
> (In reply to Jeff Muizelaar [:jrmuizel] from comment #10)
> > Risk to taking this patch (and alternatives if risky): Mobile only, 
> 
> What's the risk to mobile? Since this isn't a release blocker, we want to
> make sure it carries no additional risk if approved.

The risk should be pretty minimal. The code is removing code that is currently quite broken.
Renomming - blocks a blocker.
blocking-fennec1.0: - → ?
Attachment #628419 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/53f969bc9a2f
status-firefox14: --- → fixed
status-firefox15: --- → fixed
blocking-fennec1.0: ? → +
You need to log in before you can comment on or make changes to this bug.