Build break for debug build

RESOLVED DUPLICATE of bug 758093

Status

()

RESOLVED DUPLICATE of bug 758093
7 years ago
7 years ago

People

(Reporter: cyu, Assigned: cyu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Add ac_add_options --enable-debug to gonk-misc/default-gecko-config and build fails in OrientationSensor.cpp:

../../dist/include/nsTSubstring.h:52: note: the mangling of 'va_list' has changed in GCC 4.4
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp: In function 'nsresult<unnamed>::ConvertToScreenRotation(mozilla::dom::ScreenOrientation, PRUint32*)':
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp:98: warning: comparison between signed and unsigned integer expressions
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp: In function 'nsresult<unnamed>::ConvertToDomOrientation(PRUint32, mozilla::dom::ScreenOrientation*)':
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp:124: warning: comparison between signed and unsigned integer expressions
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp: In member function 'virtual void OrientationObserver::Notify(const mozilla::hal::SensorData&)':
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp:178: error: 'SensorType' has not been declared
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp: In member function 'void OrientationObserver::EnableAutoOrientation()':
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp:240: error: 'AutoOrientationEnabled' was not declared in this scope
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp: In member function 'bool OrientationObserver::LockScreenOrientation(mozilla::dom::ScreenOrientation)':
/home/cervantes/hg/mozilla-central/widget/gonk/OrientationObserver.cpp:261: error: 'aOrientations' was not declared in this scope
(Assignee)

Comment 1

7 years ago
Created attachment 626723 [details] [diff] [review]
Fix build break in assertions
Attachment #626723 - Flags: review?(mwu)

Updated

7 years ago
Attachment #626723 - Flags: review?(mwu) → review+
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
Patch doesn't apply, because it looks like bug 758093 fixed this same thing.  Duping.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → DUPLICATE
Duplicate of bug: 758093
You need to log in before you can comment on or make changes to this bug.