Arabic joining on bbcpersian.com broken if the tab is restored after Fennec loads

VERIFIED FIXED in Firefox 14

Status

()

Firefox for Android
General
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Ehsan, Assigned: jfkthame)

Tracking

Trunk
Firefox 15
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 verified, blocking-fennec1.0 +)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
I've noticed this on Aurora and I think on Nightly as well.  When I load bbcpersian.com from scratch after opening firefox it displays the text fine, but when a tab is restored when firefox starts up, parts of the text on the page still appears non-joined.
(Assignee)

Comment 1

6 years ago
Created attachment 626987 [details] [diff] [review]
patch, work around broken fonts on android when using cached font list as well as when first reading the list

I believe the problem is that the workaround in bug 706888 was only applied when initially reading the list of fonts from the filesystem, but doesn't take effect when loading the font list from the startupcache - therefore, the bug doesn't appear on first run after install/update, but does appear on subsequent launches.

This ought to fix it, by factoring out the bad-font workarounds and applying the same hacks to both the freshly-loaded and cached font lists.

Not yet tested, but tryserver build should appear at https://tbpl.mozilla.org/?tree=Try&rev=dfe27063b675 shortly if all goes well.
Assignee: nobody → jfkthame
(Reporter)

Comment 2

6 years ago
Your theory makes a lot of sense to me.
Blocks: 706888
blocking-fennec1.0: --- → ?
(Assignee)

Comment 3

6 years ago
Tryserver decided not to bother doing anything with that push :( so I've pushed it again, hope to get a result this time:
https://tbpl.mozilla.org/?tree=Try&rev=93890f7f6887
(Assignee)

Updated

6 years ago
Attachment #626987 - Flags: review?(jdaggett)

Comment 4

6 years ago
Comment on attachment 626987 [details] [diff] [review]
patch, work around broken fonts on android when using cached font list as well as when first reading the list

Looks fine.  I still hate having to do these evil per-font hacks but that's life I guess.
Attachment #626987 - Flags: review?(jdaggett) → review+
(Reporter)

Comment 5

6 years ago
I tried the try server build here, and it does indeed fix the bug.
(Assignee)

Comment 7

6 years ago
Comment on attachment 626987 [details] [diff] [review]
patch, work around broken fonts on android when using cached font list as well as when first reading the list

[Approval Request Comment]
Bug caused by (feature/regressing bug #): fix in bug 706888 was incomplete, because we have two distinct code paths for building the font list (directly, or from startup-cache)

User impact if declined: broken Arabic-script text on some devices

Testing completed (on m-c, etc.): Ehsan confirmed tryserver build with patch fixes the bug on his affected device

Risk to taking this patch (and alternatives if risky): minimal risk - mobile-only, narrowly targeted fix for broken font; patch just factors out the fix from 706888 so that both font-list codepaths can use it

String or UUID changes made by this patch: none
Attachment #626987 - Flags: approval-mozilla-aurora?
blocking-fennec1.0: ? → +
https://hg.mozilla.org/mozilla-central/rev/1585459db40a
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Comment on attachment 626987 [details] [diff] [review]
patch, work around broken fonts on android when using cached font list as well as when first reading the list

Please land ASAP for the Fennec beta build.
Attachment #626987 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
status-firefox14: --- → fixed
(Reporter)

Comment 11

6 years ago
Jonathan, did this get stuck on Aurora?  I still see the bug there...
(Assignee)

Comment 12

6 years ago
AFAIK, this should be on Aurora - could you double-check exactly what build you're using and confirm the steps that reproduce the bug? Is it still happening when restoring tabs?
(Reporter)

Comment 13

6 years ago
I'm using the latest Aurora nightly.  Now Arabic joining seems to be completely broken for some fonts, no matter when the tabs are restored or when you navigate to them from scratch.

Nightly seems to work just fine though...
(Assignee)

Comment 14

6 years ago
It sounds like you may be seeing yet another issue, then (sigh).... could you give a specific URL that shows the problem, along with a screenshot of the result you see?
(Reporter)

Comment 15

6 years ago
bbcpersian.com, will attach the screenshot in a sec.
(Reporter)

Comment 16

6 years ago
Created attachment 629869 [details]
screenshot on aurora
(Reporter)

Comment 17

6 years ago
Comment on attachment 629869 [details]
screenshot on aurora

The text of the news articles appears to always join properly, but the headline font on the article pages is not joined.  This bug however manifests itself on the homepage much better though, as seen here.
(Assignee)

Comment 18

6 years ago
Sorry, I'm at a loss here.... AFAICS, the same Arabic-font fixes are present in both Aurora and Nightly. I can't reproduce the issue locally, as I don't have a device that suffers from the broken-DroidSansArabic problem.
Ehsan, which build are you running?
(Reporter)

Comment 20

6 years ago
I'm running Aurora nightly from 2012-06-04 (according to about:firefox).

Any chance you can install the fonts I attached to bug 706888 and see if you can reproduce this?

Comment 21

6 years ago
The text including the headline is joined.

I verified this on: LG Optimus 2X (Android 2.2.2)
Builds:
- Nightly 16.0a1 (2012-06-06)
- Aurora 15.0a2 (2012-06-06)
- Firefox 14.0 Beta 6 (2012-06-06)

Marking it as verified fixed, please reopen if you still can see the bug.
Status: RESOLVED → VERIFIED
status-firefox14: fixed → verified
You need to log in before you can comment on or make changes to this bug.