First repaint of new Gaia homescreen is laggy on maguro

RESOLVED WORKSFORME

Status

()

Core
Graphics
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

STR
 (1) Build from https://github.com/andreasgal/b2g
 (2) Unlock lock screen
 (3) Touch-and-pan the left side of the homescreen very quickly to about halfway across the screen

There's about a half-second delay before the screen is repainted at the new position.

The lag was lower with the previous homescreen impl.  The two main changes were (i) use of rounded borders for icons; (ii) smaller and more icons.

We can wallpaper over this with bug 725967, but it's pretty sad we can't activate the layers here in under 500ms.  Investigating.  What we know so far is
 - same problem doesn't happen on more powerful HW.  On sgs2, e.g., the lag isn't noticeable.  So it's most likely not a bug in the panning logic.
 - on a testcase that forces the page to continuously invalidate and repaint, we draw at ~18fps.  So something in the neighborhood of 60ms per paint.  That's not great but doesn't explain all of the lag.

I'm going to see if I can get some usable data out of oprofile during the lag.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.