reload only happens every other time

VERIFIED FIXED in mozilla0.9

Status

()

Core
Networking: Cache
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Jeff, Assigned: gordon)

Tracking

Trunk
mozilla0.9
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Not sure if this is a cache problem or a DOM problem.  I noticed this because I
was trying to set a cookie and reload from an onClick: e.g.

<a href="#" onClick="toggleSetting(); window.location.reload()">toggle</a>

The problem was that it was only reloading every other time so my setting never
changed :(

Then I noticed that the same thing happened when I clicked on the reload button
in the toolbar.

Anyway, it doesn't happen for all pages but here's one it does happen for:
http://houseofdistraction.com/image.size.blown.html

Note that this page was created for another bug report so ignore what it says
but notice that when you reload it, it only pops up the alert every other time
(or if bug 62288 gets fixed it will only pop up the alert once every other time).

build 2001041104

Comment 1

18 years ago
confirmed with 041204.  Alert only pops up every other load in
http://houseofdistraction.com/image.size.blown.html  Over to Cache for triage
Assignee: asa → gordon
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: Cache
Ever confirmed: true
QA Contact: doronr → tever
(Assignee)

Comment 2

18 years ago
This pops up everytime I press reload now.  Looks like it was fixed by Darin's 
recent HTTP validation fixes.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla0.9

Comment 3

17 years ago
verified 7/10 builds - all platforms
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.