IonMonkey: Differential Testing: Getting "TypeError: can't redefine non-configurable property" without ion

RESOLVED DUPLICATE of bug 758543

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 758543
6 years ago
6 years ago

People

(Reporter: decoder, Unassigned)

Tracking

(Blocks: 2 bugs, {regression, testcase})

Other Branch
x86_64
Linux
regression, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
The following testcase shows different behavior with options --ion -n -m --ion-eager vs. --no-ion on ionmonkey revision c05b873dad48:


try { evaluate("var x = stack.abstract;"); } catch(exc1) {}
this.__defineSetter__('x', eval);


$ debug64/js --ion -n -m --ion-eager test.js
<no output or error>


$ debug64/js --no-ion test.js
test.js:2: TypeError: can't redefine non-configurable property 'x'
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 758543
You need to log in before you can comment on or make changes to this bug.