Saving File dialog should say Close, not Cancel, at 100%

VERIFIED DUPLICATE of bug 74011

Status

SeaMonkey
General
--
minor
VERIFIED DUPLICATE of bug 74011
17 years ago
13 years ago

People

(Reporter: Casey Perkins, Assigned: Matthew Paul Thomas)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The Saving File dialog, which can now stay open after a download is finished,
continues to have a Cancel button even after the download is complete. This is
misleading to the user, causing some to be not entirely sure whether the file
will still be there if they were to click Cancel. "Cancel" denotes that an
action will be aborted.
The Saving File dialog should say "Cancel" up until the download is complete;
then that button should change to read "Close," making its real use more clear
to the user.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
The fix for this just got checked in.

*** This bug has been marked as a duplicate of 74011 ***

Comment 2

17 years ago
bz: thanks, you rock for finding this!
Status: RESOLVED → VERIFIED

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.