Firefox can't handle the playback of webm content on my pc

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: macster_smart, Unassigned)

Tracking

12 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

I have an old Athlon XP 2600+ with a Radeon 9600 Pro video card but still Firefox seems unable to use hardware acceleration on this specs while playing webm video.
Youtube webm videos barely can play even at 360p windowed mode the CPU usage hits 100%, in Fullscreen mode I get like 3-5 video frames/second which cannot be considered video playback at all.
Webm 720p unable to play in windowed or Fullscreen mode at all, let alone 1080p.
Instead I've downloaded from Youtube with FlashGot the same webm clip that I was trying to play on Youtube page with Firefox and tried to see how it plays in a standalone player like VLC.
Guess what with VLC the 360p video played in windowed or Fullscreen mode using just 15% CPU usage, while the 720p version uses only about 35% CPU usage.
So why Firefox can't play webm content using such low CPU resources and making webm content actually playable ?


Actual results:

Firefox hits 100% CPU usage while playing webm video content on webpages while VLC player uses only 15% CPU resources playing the same video.


Expected results:

Try fix this **** sooner than later. :)

Comment 1

6 years ago
Copy the section about Graphics from about:support
(Reporter)

Comment 2

6 years ago
(In reply to Jesper Hansen from comment #1)
> Copy the section about Graphics from about:support
This is it:
Graphics 
Adapter Description: GIGABYTE RADEON 9600 PRO
Vendor ID: 0x1002
Device ID: 0x4150
Adapter RAM: Unknown
Adapter Drivers: ati2dvag
Driver Version: 8.582.0.0
Driver Date: 2-3-2009
WebGL Renderer: Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.
GPU Accelerated Windows: 0. Blocked for your graphics driver version. Try updating your graphics driver to version 10.6 or newer.

The Graphics card has 128 MB Ram even if it's listed as Unknown, and I'm using the latest driver and best one so far for this card since ATI/AMD doesn't support this device anymore and they don't provide driver updates anymore, so the advice to upgrade to version 10.6 or higher is PURE NONSENSE since there's no such version nor newer. 
So yeah F*CK Mozilla for screwing things up.

Comment 3

6 years ago
You're expecting old technology to work with new technology.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 4

6 years ago
(In reply to Jesper Hansen from comment #3)
> You're expecting old technology to work with new technology.

It would have been worked if it weren't for your stupid rules with driver versions.
Looks like new technology comes packed with new stupidity too, the irony is sweet sometimes. lol
(Reporter)

Comment 5

6 years ago
At least is there a way to bypass Mozilla's stupid rules and force Firefox to use Graphics acceleration anyway ?
You need to log in before you can comment on or make changes to this bug.