Treat text/jscript (and others, per HTML5) as a synonym for text/javascript

RESOLVED DUPLICATE of bug 672814

Status

()

RESOLVED DUPLICATE of bug 672814
7 years ago
7 years ago

People

(Reporter: boterogomezalex, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 627237 [details]
pagina.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

I have created a web page that initialize a javascript object with certain information, later after loading the web page FireFox can't read any property, a proved that page in IE, Opera, Safari and Chrome and it works perfectly but it doesn't work in FF.


Actual results:

It seems that FF never execute the javascript code, for instance, I put alert messages before and after and but those messages but never poped up, the variable used never is initialized and it causes that the page doesn't work.

the attachment is the whole page without extern files, but you can go the http://omega.compuhora.com.co/alphasig_testing/


Expected results:

the object have to be initialized and the page works normally.
(Reporter)

Updated

7 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
(Reporter)

Comment 1

7 years ago
Created attachment 627240 [details]
error message

this is the error message
(Reporter)

Updated

7 years ago
Attachment #627237 - Attachment mime type: text/plain → text/html
The datasServidor variable is initialized in a script that looks like this:

  <script type="text/jscript" language="javascript">

You probably want type="text/javascript" there, since "jscript" is technically only implemented by IE...  Similar in some of the other script tags on the page.

That said, HTML5 seems to have given up on that and has a nice long list of things that browsers should pretend are actually JavaScript, at http://www.whatwg.org/specs/web-apps/current-work/multipage/scripting-1.html#scriptingLanguages

Ms2ger, want to patch?  ;)
Assignee: general → nobody
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM
Ever confirmed: true
QA Contact: general → general
Summary: FF can't initialize a javascript object → Treat text/jscript (and others, per HTML5) as a synonym for text/javascript
And hey, we had a bug on this already.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 672814
You need to log in before you can comment on or make changes to this bug.