Need publicly visible FTP directory for public B2G files

RESOLVED FIXED

Status

Infrastructure & Operations
Infrastructure: Other
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: jgriffin, Assigned: digi)

Tracking

Details

(Reporter)

Description

6 years ago
In bug 751974, a password-protected download directory was created for non-public B2G build artifacts: https://releases.mozilla.com/b2g/

We'd like a corresponding publicly visible directory where we could store public build artifacts.  Currently, these would just be build manifests that could be used by anyone to reproduce one of the non-public builds, but soon we hope to be able to post emulator builds publicly as well.

Perhaps we could use https://releases.mozilla.com/b2g-public/
Assignee: server-ops → server-ops-infra
Component: FTP: Staging → Server Operations: Infrastructure
QA Contact: mrz → jdow
(Assignee)

Comment 1

6 years ago
:jgriffin

I've created https://releases.mozilla.com/b2g-public, since this isn't password protected it will also work without SSL. I've granted the same write permissions on b2g-public as b2g, so the same users will be able to upload.

Just in case, here's the full path:

stage.mozilla.org:/mnt/netapp/stage/releases.mozilla.com/b2g-public
Assignee: server-ops-infra → bhourigan
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
We also have http://ftp.mozilla.org/pub/mozilla.org/b2g/ now for the builds RelEng infrastructure is producing, which is also unrestricted. Perhaps it's worth just using one of these locations to avoid confusion ?
(Assignee)

Comment 3

6 years ago
:nthomas

I agree. Thanks for catching this.

:jgriffin

Do you have a preference on which location to use?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 4

6 years ago
I agree with :nthomas, it makes sense to keep all the public B2G files in the same location.
(Assignee)

Comment 5

6 years ago
I've removed stage.mozilla.org:/mnt/netapp/stage/releases.mozilla.com/b2g-public in favor of stage.mozilla.org:/mnt/netapp/stage/archive.mozilla.org/pub/mozilla.org/b2g, public url http://ftp.mozilla.org/pub/mozilla.org/b2g/
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Component: Server Operations: Infrastructure → Infrastructure: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.