Please Profile Me Mr Hyatt (dead UI during page load)

RESOLVED WORKSFORME

Status

()

Core
Layout
--
major
RESOLVED WORKSFORME
17 years ago
17 years ago

People

(Reporter: Hixie (not reading bugmail), Assigned: Chris Waterson)

Tracking

({perf, testcase})

Trunk
x86
Windows 2000
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I went to:
   http://www.phpbuilder.net/mail/php-db/2000082/index.php
...and layout was REALLY slow and starved the UI thread while CPU pegged to 100%
after a single reflow (that I could see).

I saved a local copy of this page with all links neutered (so as to make the 
test completely reproducable in the future):
   http://www.damowmow.com/mozilla/bugs/slow/003.html

I would appreciate it if you could profile this test page to determine where we
are sucking, hopefully resulting in this bug being marked a duplicate of a
pre-existing perf bug, but maybe resulting in the discovery of a new flaw in
Layout or Style or something.
(Reporter)

Updated

17 years ago
Keywords: mozilla0.9.1, perf, testcase

Comment 1

17 years ago
--> waterson.  Probably a dup of long page perf bugs.
Assignee: hyatt → waterson

Comment 2

17 years ago
wonder if this is fixed now... the page loaded pretty zippy
for me even over a 28.8 dialup connection using a recent
trunk build.
(Assignee)

Comment 3

17 years ago
I see some <form> tags with an unclosed <font> tag. If I had to guess, this'd be
triggering the {ib} code, and we probably got a big boost from fixing bug 58674.
Anyway, the page loads within a reasonable amount of time AFAICT. Ian, marking
WORKSFORME; let me know if I'm missing something?
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.