Panning yields black artifacts amidst low-resolution tiles

RESOLVED DUPLICATE of bug 759762

Status

()

Firefox for Android
General
--
major
RESOLVED DUPLICATE of bug 759762
6 years ago
6 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({regression, reproducible})

Trunk
ARM
Android
regression, reproducible
Points:
---

Firefox Tracking Flags

(firefox14 unaffected, firefox15 affected, blocking-fennec1.0 +)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 627342 [details]
Nightly (20120524) - Screenshot (Galaxy Nexus, 4.0.4)

Not sure if there's a bug already on this ...

Recent regression on trunk (Nightly 20120525) is revealing black artifacts shown amidst the low-resolution tiles during fast panning on an assortment of pages.

To illustrate exactly what I am seeing, see attached screenshot.

Steps to Reproduce :: http://www.arstechnica.com, http://www.neowin.net, conduct some fast pans

--
Tested via: Samsung Galaxy Nexus (Android 4.0.4)
Mozilla/5.0 (Android; Mobile; rv:15.0) Gecko/15.0 Firefox/15.0a1
(Reporter)

Updated

6 years ago
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

6 years ago
tracking-fennec: --- → ?
Keywords: reproducible
I think I saw something similar on the HTC Desire testing bug 757920.
The screenshot makes it look like java screenshot layer is confused about where things should be. I've seen something like this as well.
(Reporter)

Updated

6 years ago
Duplicate of this bug: 759048
Following the steps from the duplicate bug (bug 759048):
good build: May 24th
bad build: May 25th

Possible regression-range:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f43e8d300f21&tochange=1dd0c5c6d9fd
Keywords: regression, regressionwindow-wanted
My guess is this is caused by bug 748384 but it would be nice to have the regressionwindow narrowed down further.
(Reporter)

Updated

6 years ago
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

6 years ago
Severity: normal → major
Inbound builds:

May 23 1337822875 – good
May 23 1337825996 – bad

Possible inbound regression range:
 http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a2a6aee1aaca&tochange=19dbf7300434
Keywords: regressionwindow-wanted
Blocks: 748384
blocking-fennec1.0: --- → ?
I believe this was fixed with the patch from bug 759762. The build at http://stage.mozilla.org/pub/mozilla.org/mobile/tinderbox-builds/mozilla-central-android/1338466586/ has this patch and I cannot reproduce the problem on that build (at least on arstechnica.com). Could somebody else confirm just to make sure? Then we can dupe this to bug 759762.
(Reporter)

Comment 8

6 years ago
This is fixed; I am unable to reproduce anymore either. I'm testing on an inbound build from this morning -- 05/31 using my original STR and also gave planet.mozilla and a Tumblr blog a pan through.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 759762
Awesome, thanks.
tracking-fennec: ? → ---
blocking-fennec1.0: ? → +
You need to log in before you can comment on or make changes to this bug.