Last Comment Bug 758782 - makefiles: declare mkdir_deps targets .PRECIOUS
: makefiles: declare mkdir_deps targets .PRECIOUS
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla15
Assigned To: Joey Armstrong [:joey]
:
Mentors:
: 758780 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-25 14:07 PDT by Joey Armstrong [:joey]
Modified: 2012-06-01 08:12 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mkdir_deps dependencies should be .PRECIOUS (2.37 KB, patch)
2012-05-25 14:31 PDT, Joey Armstrong [:joey]
mh+mozilla: review+
Details | Diff | Review
mkdir_deps dependencies should be .PRECIOUS (2.37 KB, patch)
2012-05-30 10:56 PDT, Joey Armstrong [:joey]
no flags Details | Diff | Review

Description Joey Armstrong [:joey] 2012-05-25 14:07:40 PDT
mkdir_deps generated dependencies will be considered an intermediate file and removed when used as a pre-requisite for a wildcard target.

Add ".PRECIOUS: %/.mkdir.done" within config/makefiles/autotargets.mk to inhibit the behavior.  Problem surfaced while compiling idl files { toolkit/components/alerts }.

libalerts_s.a may also suffer from a similar problem:
nsAlertsService.cpp
/usr/bin/ccache c++ -o nsAlertsService.o [...]
rm -f libalerts_s.a
Comment 1 Joey Armstrong [:joey] 2012-05-25 14:11:26 PDT
*** Bug 758780 has been marked as a duplicate of this bug. ***
Comment 2 Joey Armstrong [:joey] 2012-05-25 14:31:28 PDT
Created attachment 627370 [details] [diff] [review]
mkdir_deps dependencies should be .PRECIOUS
Comment 3 Joey Armstrong [:joey] 2012-05-25 14:33:41 PDT
Comment on attachment 627370 [details] [diff] [review]
mkdir_deps dependencies should be .PRECIOUS

Flag directory creation deps as .PRECIOUS to inhibit removal when they are considered an "intermediate file".
Comment 4 Mike Hommey [:glandium] 2012-05-30 07:09:26 PDT
Comment on attachment 627370 [details] [diff] [review]
mkdir_deps dependencies should be .PRECIOUS

Review of attachment 627370 [details] [diff] [review]:
-----------------------------------------------------------------

::: config/makefiles/autotargets.mk
@@ +18,5 @@
>  MKDIR ?= mkdir -p
>  TOUCH ?= touch
>  
> +# Deps will be considered intermediate when used as a pre-requisite for
> +# wildcard targets.  Inhibit their removal, mkdir -p is a standlaone op.

typo in standalone
Comment 5 Joey Armstrong [:joey] 2012-05-30 10:56:23 PDT
Created attachment 628388 [details] [diff] [review]
mkdir_deps dependencies should be .PRECIOUS
Comment 6 Joey Armstrong [:joey] 2012-05-30 11:23:07 PDT
Comment on attachment 628388 [details] [diff] [review]
mkdir_deps dependencies should be .PRECIOUS

r=glandium carried forward.

Fixed typo in 'standalone' spelling.
Comment 7 Joey Armstrong [:joey] 2012-05-30 11:36:15 PDT
Try job: https://tbpl.mozilla.org/?tree=Try&rev=f47e7fde1a62
Comment 8 Joey Armstrong [:joey] 2012-05-31 14:14:52 PDT
Inbound push: https://hg.mozilla.org/integration/mozilla-inbound/rev/2e755d7847ac
Comment 9 Ed Morley [:emorley] 2012-06-01 08:12:35 PDT
https://hg.mozilla.org/mozilla-central/rev/2e755d7847ac

Note You need to log in before you can comment on or make changes to this bug.