Mozilla Marketplace website uses incorrect font for many locales

VERIFIED FIXED in 2012-07-05

Status

Marketplace
General
P1
normal
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: JasnaPaka, Assigned: potch)

Tracking

2012-07-05
Points:
---

Firefox Tracking Flags

(blocking-kilimanjaro:+)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 627379 [details]
Screenshot

1) Visit https://marketplace-dev.allizom.org/cs/
2) You can see that some chars are showed incorrectly. See screenshot.
Blocks: 752013
It looks like accented characters are coming through as a different font weight.  Potch - is this something in our CSS or is this something we'll need to address in the font?

P2 to answer that question and then we can prioritize from there.
Assignee: nobody → thepotch
Priority: -- → P2
(Assignee)

Comment 2

6 years ago
CCing sean on this.

Sean, it looks like the "Repertoire" of the font is only basic alphanumerics. Are there embeddables of the typeface that have broader unicode support? That's critical for us.
Priority: P2 → P1
Target Milestone: --- → 2012-06-07
This blocks basecamp because our target languages use plenty of accented characters.  Assigning to Sean.
Assignee: thepotch → smartell
Blocks: 766201
No longer blocks: 752013
blocking-basecamp: --- → +
blocking-kilimanjaro: --- → +
Target Milestone: 2012-06-07 → ---

Comment 4

6 years ago
The font that is on Github is apparently stripped of the other locales. This was noticed on WebFWD's site and they now reference the complete character set from Google Web Fonts. 

You can select all the sets before you download from there.
Thanks.  -> potch
Assignee: smartell → thepotch
Target Milestone: --- → 2012-07-05
Duplicate of this bug: 753037
(Assignee)

Comment 7

5 years ago
Lookin good in all locales. Bigger file sizes, natch. 
https://github.com/mozilla/zamboni/commit/45a30bf
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 8

5 years ago
looks fixed to me.
Status: RESOLVED → VERIFIED

Comment 9

5 years ago
Created attachment 640675 [details]
post-fix screenshot
Not on-device - removing nom.
blocking-basecamp: + → ---
You need to log in before you can comment on or make changes to this bug.