java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp$FilePickerResultHandler.handleActivityResult(GeckoApp.java)

RESOLVED FIXED in Firefox 14

Status

()

--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: scoobidiver, Assigned: kats)

Tracking

({crash})

Trunk
Firefox 15
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox14 fixed, blocking-fennec1.0 soft)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
There are six crashes over the last four weeks, including this crash report: bp-01ef0e0d-c82b-4832-b0af-516da2120526.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApp$FilePickerResultHandler.handleActivityResult(GeckoApp.java:2618)
	at org.mozilla.gecko.GeckoApp$FilePickerResultHandlerSync.onActivityResult(GeckoApp.java:2669)
	at org.mozilla.gecko.GeckoApp.onActivityResult(GeckoApp.java:2609)
	at android.app.Activity.dispatchActivityResult(Activity.java:4649)
	at android.app.ActivityThread.deliverResults(ActivityThread.java:3099)
	at android.app.ActivityThread.handleSendResult(ActivityThread.java:3146)
	at android.app.ActivityThread.access$1100(ActivityThread.java:132)
	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1187)
	at android.os.Handler.dispatchMessage(Handler.java:99)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4575)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:789)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:556)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?signature=java.lang.NullPointerException%3A+at+org.mozilla.gecko.GeckoApp%24FilePickerResultHandler.handleActivityResult%28GeckoApp.java%29
Created attachment 627819 [details] [diff] [review]
Patch
Assignee: nobody → bugmail.mozilla
Attachment #627819 - Flags: review?(blassey.bugs)
Comment on attachment 627819 [details] [diff] [review]
Patch

Review of attachment 627819 [details] [diff] [review]:
-----------------------------------------------------------------

logic is hard
Attachment #627819 - Flags: review?(blassey.bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/4c8dfa5b92ea
status-firefox14: --- → affected
status-firefox15: --- → fixed
Target Milestone: --- → Firefox 15

Comment 4

6 years ago
https://hg.mozilla.org/mozilla-central/rev/4c8dfa5b92ea
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Comment on attachment 627819 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 741284
User impact if declined: possible crashes when using file picker
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): mobile only, low risk
String or UUID changes made by this patch: none
Attachment #627819 - Flags: approval-mozilla-aurora?

Updated

6 years ago
blocking-fennec1.0: --- → ?
blocking-fennec1.0: ? → soft
Attachment #627819 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Reporter)

Comment 7

6 years ago
There are crashes in 14.0b5 that contains the fix.
Status: RESOLVED → REOPENED
status-firefox14: fixed → affected
status-firefox15: fixed → ---
Resolution: FIXED → ---
14.0b5 doesn't contain the fix, it looks like.

kats@kgupta-air mozilla-aurora$ hg log -r "ancestor(FENNEC_14_0b5_RELEASE,81592bd79815)"
changeset:   94417:89176b6d643c
user:        Boris Zbarsky <bzbarsky@mit.edu>
date:        Tue May 29 00:17:45 2012 -0400
summary:     Bug 758885.  Don't apply the dynamic :hover reresolution skipping optimization to selectors which can match on mutable state other than :hover.  r=dbaron, a=akeybl

The latest common ancestor of my patch and the 14.0b5 is not my patch, which means my patch isn't in 14.0b5.
(Reporter)

Comment 9

6 years ago
(In reply to Kartikaya Gupta (:kats) from comment #8)
> 14.0b5 doesn't contain the fix, it looks like.
I disagree. See the changelog between 14.0b3 and 14.0b5: http://hg.mozilla.org/releases/mozilla-aurora/pushloghtml?fromchange=fcd3d27d53c6&tochange=3dbfe52b2649
That changelog includes changes pushed on all branches of the mozilla-aurora tree. As you can see, it includes Brad's looper changes twice, which doesn't make sense if they were all on the same branch. This is a better view: https://hg.mozilla.org/releases/mozilla-aurora/graph/94448 - the points on the yellow line are the changes that went into b5, and the points on the green line did not. b5 is basically b4 plus the patches from bug 759146 and bug 758010.
(Reporter)

Updated

6 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
status-firefox14: affected → fixed
Resolution: --- → FIXED
(Reporter)

Comment 11

6 years ago
There's one crash in 14.0b6: bp-5200426d-13e8-4297-9e19-42b8c2120609.
You need to log in before you can comment on or make changes to this bug.