Save As PDF renders JPEGs as black rectangles (Android 2.3.4 / HTC)

RESOLVED DUPLICATE of bug 704185

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 704185
6 years ago
6 years ago

People

(Reporter: Jefferson, Unassigned)

Tracking

Firefox 10
ARM
Android

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 627495 [details]
PDF capture from http://www.carrferrell.com/trademark-law/ with a mix of PNG and JPEG images

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Save As PDF in Firefox Mobile 10.0.4


Actual results:

JPEG images that display correct on the screen render as black rectangles in the PDF. This is true whether viewed in Adobe Reader 10.2.1 on Android 2.3.4 or in Adobe Reader 10.1.3 on Windows XP.


Expected results:

JPEG images should be converted correctly.
(Reporter)

Comment 1

6 years ago
Created attachment 627496 [details]
PDF capture from http://jeffersonscher.com/photos/Maui07/index.php

Foreground JPEG images rendered as black rectangles
(Reporter)

Comment 2

6 years ago
Created attachment 627497 [details]
PDF capture of http://www.jeffersonscher.com/ with JPEG background image

Entire area of background image rendered as opaque black; only Google Custom Search form controls are visible (with the Google logo placeholder also rendered as a black rectangle).

Sorry about the cc's!
This should currently be fixed on the Beta product on Google Play, Firefox Beta (version 14).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704185

Updated

6 years ago
Component: General → General
OS: Windows XP → Android
Product: Fennec Native → Fennec
Hardware: x86 → ARM
Version: unspecified → Firefox 10
You need to log in before you can comment on or make changes to this bug.