Toolbar only partially displayed after closing and re-opening

VERIFIED FIXED

Status

P3
normal
VERIFIED FIXED
20 years ago
2 years ago

People

(Reporter: asa, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
TOPIC: Display Problem for the Main Toolbar (toolbar containing the
back,forward,reload,stop buttons as well as the URL bar) After Closing and
Re-opening.

STEPS TO REPRODUCE:  Launch Apprunner.  Click on the blue 'grippy' to close the
main toolbar.  Click on the grippy again to open the toolbar.

EXPECTED BEHAVIOR:  Toolbar should open and appear complete as it does before
initial closing.

ACTUAL BEHAVIOR:  Reload, translate, Print and Throbber buttons disappear
(functionality for these buttons remains in tact.  Background behind buttons
disappear.  Some links or other elements from the sidebar show through the
toolbar.

OTHER STUFF:  The bottom toolbar opens and closes normally but is affected the
same as the main toolbar when the main toolbar is closed and opened (all buttons
 disappear and grippy disappears as well unles it gets focus on mouse-over)
(Reporter)

Comment 1

20 years ago
ADDITIONAL COMMENTS:  Bug discovered on build 6/02 08.  Also, toolbar tests
under 'DEBUG' L> 'XPTOOLKIT' L> 'TOOLBAR' and 'TAB' works fine.  Toolbar closes
and opens normally.
(Reporter)

Updated

20 years ago
OS: Windows 95 → Windows NT
(Reporter)

Comment 2

20 years ago
Same or similar problem on WIN NT 4.0 Service Pack 3 (Pentium II 350 64 MB RAM)  running build 199060308

Comment 3

20 years ago
adding to cc list, as this affects mozine chrome also in bug
http://bugzilla.mozilla.org/show_bug.cgi?id=6531 when toolbar buttons are
disabled by hand
(Assignee)

Updated

20 years ago
Assignee: don → pinkerton
(Assignee)

Comment 4

20 years ago
this is my bug. assigning to me. this may be a dupe of 6531 though. Not sure.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 5

20 years ago
accepting bug. There's gotta be something weird with that top toolbar because the
toolbar test works just fine. What makes it so different?

Updated

20 years ago
QA Contact: leger → claudius

Comment 6

20 years ago
Updating QA Contact to claudius...the "toolbar man" :-)
(Assignee)

Comment 7

20 years ago
*** Bug 7591 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

20 years ago
more info from asa:
Windows95 P90 32 MB RAM Build 060408
Other toolbars function normally but both are hosed when the main toolbar
is closed and re-opened.  After re-opening main toolbar buttons appear inactive (grayed out image and text).
No apparent sequence of closing and opening other toolbars prevents problem.  Problem happens with or without text in the URL bar.  Problem happens regardless of window size and is unaffected by window resizing after toolbar is broken.
(Reporter)

Comment 9

20 years ago
Win32 build from the 9th (ID 60910) as well as experimental build from the 9th
(ID 60916) behave a little differently. I'm testing on NT4.0.  Builds from the
sixth and 8th lost the reload, translate, print and throbber buttons (visually
lost, still functional).  With builds from the ninth a mouse-over brings the
buttons back (background still missing)  The reload, translate, print and
throbber buttons return on mouse-over to their dark blue color while the back,
forward and stop buttons look lighter (inactive color?).

Comment 10

20 years ago
hey pink, if evaughn is working on this can we just go ahead and mark it as a dupe of bug 6531? Or do you want to hold on to
this for some reason?
(Reporter)

Comment 11

20 years ago
Toolbars functioning properly on 6/12/99 build under win32 win95.
(Reporter)

Comment 12

20 years ago
New buggy behavior with main toolbar.  back, forward and stop appear inactive.  The text for the words "Back", "Forward" and "Stop" is grayed out but the buttons appear to function properly.  Is this a new bug, or is it part of the same bug?  It is unaffected by closing and opening of toolbars so I suspect that this is a seperate bug.
(Reporter)

Comment 13

20 years ago
Toolbar closing and opening broken again in 6/13 win32 build (tested on NT4).
6/12 toolbar closing and re-opening works on NT.
(Assignee)

Comment 14

20 years ago
*** Bug 7985 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

20 years ago
Hrm, this appears fixed in today's build. Grippies don't draw correctly when
collapsed, but that's just a css problem. However, I can now collapse and expand
the main toolbar to my heart's content w/out mucking up the main window.
(Assignee)

Updated

20 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

20 years ago
i didn't fix anything, but this works now. marking fixed.

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 17

20 years ago
VERIFIED fixed for WinNT with 1999061514 build

Comment 18

20 years ago
Moving all Apprunner bugs past and present to Other component temporarily whilst
don and I set correct component.  Apprunner component will be deleted/retired
shortly.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.