ScriptFactory should haltOnFailure in clobber_scripts

RESOLVED FIXED

Status

Release Engineering
General
--
minor
RESOLVED FIXED
6 years ago
15 days ago

People

(Reporter: philor, Assigned: philor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 627512 [details] [diff] [review]
fix

Unless I'm forgetting or not thinking of some way for "rm -rf scripts" to fail, if it fails then the directory is going to still exist, so the next step, clone_scripts, is going to fail with "destination exists" and haltOnFailure, and we'll get a log like https://tbpl.mozilla.org/php/getParsedLog.php?id=12042013&tree=Jetpack when we might as well have it failing where the problem is, permission denied, rather than where the fallout is, destination exists.
Attachment #627512 - Flags: review?(catlee)

Updated

6 years ago
Attachment #627512 - Flags: review?(catlee) → review+
(Assignee)

Updated

6 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.