Closed Bug 758997 Opened 8 years ago Closed 6 years ago

Can't drop some links on Bookmarks toolbar

Categories

(Core :: DOM: Drag & Drop, defect, minor)

defect
Not set
minor

Tracking

()

VERIFIED FIXED
mozilla29

People

(Reporter: mats, Assigned: mats)

Details

(Keywords: regression, testcase, Whiteboard: [good first verify])

Attachments

(2 files, 1 obsolete file)

Attached file testcase
STEPS TO REPRODUCE
1. load attached testcase
2. Enable Bookmarks Toolbar (View->Toolbars)
3. drag the "Bookmarklet1" link and drop it on the toolbar

ACTUAL RESULT
drop fails

EXPECTED RESULT
a link on the toolbar titled "Bookmarklet1"

ADDITIONAL INFORMATION
it works for the other two links
it regressed some time between Firefox 3.6 and 4.0
Attached patch wip (obsolete) — Splinter Review
This seems to fix it.  It appears the problem is the <ul><li> context
makes us add a newline before and after "Bookmarklet1".  This makes
PlacesUtils::unwrapNodes throw and PlacesControllerDragHelper::canDrop
return false, since the expected format is url\ntitle for the x-moz-url
data.

Pushed to Try (together with the fix for bug 703514):
https://tbpl.mozilla.org/?usebuildbot=1&tree=Try&rev=07befd81cf25
Attached patch fixSplinter Review
https://tbpl.mozilla.org/?tree=Try&rev=296408674423
Assignee: nobody → matspal
Attachment #627601 - Attachment is obsolete: true
Attachment #8355097 - Flags: review?(bzbarsky)
Comment on attachment 8355097 [details] [diff] [review]
fix

r=me
Attachment #8355097 - Flags: review?(bzbarsky) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/57e1604ca1b2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Whiteboard: [good first verify]
[testday-20140411]
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0

This issue is fixed on Windows 7 SP1 x64, using the latest Beta (20140410150427).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.