If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Cannot move or copy folders using keyboard only (implement "Move to" / "Copy To" contextual actions for folders)

RESOLVED DUPLICATE of bug 404955

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 404955
5 years ago
5 years ago

People

(Reporter: Valerio Messina, Unassigned)

Tracking

({access})

12 Branch
access

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Select a mail folder
right click on folder
or
Message menù



Actual results:

the items "Move To" & "Copy To" is grayed.
Grayed for:
"Local folder, folder in 1st level under root, right click/context menù"
"Local folder, all other folders, Message menù and right click/context menù"
"IMAP folder, every folder, Message menù and right click/context menù"
Work for:
"Local folder, folder in 1st level under root, using Message menù only"



Expected results:

the items "Move To" & "Copy To" should be selectable and work

I can move or copy a those folders only using mouse drag&drop, no keyboard sequence work
(Reporter)

Updated

5 years ago
OS: Windows XP → All
Hardware: x86 → All

Comment 1

5 years ago
(In reply to Valerio Messina from comment #0)
Individual messages under those folders can be selected then copied or moved, but the folder itself cannot be copied or moved from the menu itself.
(Reporter)

Comment 2

5 years ago
right, individual message (or multiple selection of messages) can always copied and moved with both Message menù or contextual menù.
The bug happen with folder only. Some folder con be moved or copied only by drag&drop (so only by mouse).
Valerio, thanks for pointing out this accessibility problem. It is currently not possible to move or copy *folders* using keyboard only. I am suprised you say it works in a certain case (cannot reproduce), but if it does, that's a bug :)

Obviously, we cannot use the existing "*Message* > Copy/Move to" menus for *folders*, but we could add a "Copy Folder to" and "Move Folder to" command to File or Edit menu.

Bug 512942 requests to enable Ctrl+C, Ctrl+X, Ctrl+V for copying/moving messages around, which should certainly include folders as well.
Keywords: access
Summary: miss Message>"Move To" & Message>"Copy To" menu item for folders → Cannot move or copy folders using keyboard only (implement "Move to" / "Copy To" contextual actions for folders)
(In reply to Thomas D. from comment #3)
> Bug 512942 requests to enable Ctrl+C, Ctrl+X, Ctrl+V for copying/moving
> messages around, which should certainly include folders as well.

For Address book, that's Bug 339227.

And there must be something for folders if we only search hard enough...
BMO QuickSearch for :thun,mail summary:folder summary:ctrl+c,copy
https://bugzilla.mozilla.org/buglist.cgi?quicksearch=%3Athun%2Cmail%20summary%3Afolder%20summary%3Actrl%2Bc%2Ccopy;list_id=3291943

...found! Here it is:
Bug 404955

I've tweaked the summary of bug 404955 to better describe the problem and possible solutions and to improve retrievability.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404955
For completeness of reference:

Keyboard ways of copying/moving, using
- Ctrl+C, Ctrl+X, or
- context menu "Copy to" / "Move to":

Bug 512942 for messages (Ctrl+C, Ctrl+X only)
Bug 404955 for folders
Bug 339227 for address book items
Bug 335783 for attaching imgs/msgs/files/anything from clipboard
(Reporter)

Comment 6

5 years ago
(In reply to Thomas D. from comment #3)
> I am suprised
> you say it works in a certain case (cannot reproduce), but if it does,
> that's a bug :)

I checked exactly when work and when not.
If you select a folder, and no message is selected, the Move/Copy To is grayed, and this is right.

On the other side, if you select a message in a folder, then select the folder itself.
The message is grayed, and the folder has the blu bar. In this situation the Message menù has the Move/Copy To item, and while a folder is selected, the command act on the message.
Probably this is not a bug, but is counterintuitive.
You need to log in before you can comment on or make changes to this bug.