Last Comment Bug 759078 - Permanent orange: TEST-UNEXPECTED-FAIL | test_mime_emitter.js - Assertion failure: !connections[i]->ConnectionReady(), mozStorageService.cpp:852
: Permanent orange: TEST-UNEXPECTED-FAIL | test_mime_emitter.js - Assertion fai...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Database (show other bugs)
: 12
: All All
: -- blocker (vote)
: Thunderbird 15.0
Assigned To: Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
:
:
Mentors:
Depends on:
Blocks: 711076
  Show dependency treegraph
 
Reported: 2012-05-28 04:31 PDT by Mark Banner (:standard8)
Modified: 2012-06-05 13:01 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
call GlodaDatastore.shutdown (722 bytes, patch)
2012-05-28 07:16 PDT, Rafael Ávila de Espíndola (:espindola) (not reading bugmail)
standard8: review+
Details | Diff | Splinter Review

Description Mark Banner (:standard8) 2012-05-28 04:31:47 PDT
Since bug 711076 landed, when running test_mime_emitter.js in debug mode, we're seeing:

Assertion failure: !connections[i]->ConnectionReady(), at ../../../../mozilla/storage/src/mozStorageService.cpp:852

https://tbpl.mozilla.org/php/getParsedLog.php?id=12127233&tree=Thunderbird-Try#error0

TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | test failed (with xpcshell return code: 1), see following log:
>>>>>>>
### XPCOM_MEM_LEAK_LOG defined -- logging leaks to /tmp/tmpyhymf9/runxpcshelltests_leaks.log
WARNING: NS_ENSURE_TRUE(!(accountList.IsEmpty())) failed: file ../../../../mailnews/base/src/nsMsgAccountManager.cpp, line 1343

TEST-INFO | (xpcshell/head.js) | test 1 pending
Directory request for: MailD that we (mailDirService.js) are not handling, leaving it to another handler.
Directory request for: MFCaF that we (mailDirService.js) are not handling, leaving it to another handler.
Directory request for: DefRt that we (mailDirService.js) are not handling, leaving it to another handler.

TEST-INFO | (xpcshell/head.js) | test 2 pending

TEST-INFO | (xpcshell/head.js) | test 3 pending

TEST-INFO | (xpcshell/head.js) | test 3 finished

TEST-INFO | (xpcshell/head.js) | running event loop
WARNING: GetDefaultCharsetForLocale: need to add multi locale support: file ../../../../../../mozilla/intl/locale/src/unix/nsUNIXCharset.cpp, line 105
2012-05-28 02:00:56	test.test	INFO	[Context: test.test:1 state: started] Starting test: test_stream_message, text/plain

TEST-INFO | (xpcshell/head.js) | test 3 pending

TEST-INFO | (xpcshell/head.js) | test 3 finished

TEST-INFO | (xpcshell/head.js) | test 2 finished
Directory request for: Home that we (mailDirService.js) are not handling, leaving it to another handler.
Directory request for: UMimTyp that we (mailDirService.js) are not handling, leaving it to another handler.
Directory request for: UMimTyp that we (mailDirService.js) are not handling, leaving it to another handler.

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [verify_body_part_equivalence : 363] text/plain == text/plain

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [verify_body_part_equivalence : 372] text/plain; charset=ISO-8859-1; format=flowed == text/plain; charset=ISO-8859-1; format=flowed

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [verify_body_part_equivalence : 378] I am text! Woo! == I am text! Woo!
Everything is just fine.
Synthetic looks like:
  Message: Green Report Very Important
  1 Leaf: text/plain

MIME looks like:

Skipping 1763 lines...

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [null : 566] application/x-funky == application/x-funky

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [null : 566] message/rfc822 == message/rfc822

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [null : 575] 0 == 0

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [null : 575] 0 == 0

TEST-INFO | (xpcshell/head.js) | test 2 pending
2012-05-28 02:00:57	test.test	INFO	[Context: test.test:33 state: finished] Finished test: test_attachments_correctness
2012-05-28 02:00:57	test.test	INFO	[Context: test.test:34 state: started] Starting test: test_part12_not_an_attachment

TEST-INFO | (xpcshell/head.js) | test 3 pending

TEST-INFO | (xpcshell/head.js) | test 3 finished

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [null : 617] true == true

TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/mailnews/db/gloda/test/unit/test_mime_emitter.js | [null : 618] true == true

TEST-INFO | (xpcshell/head.js) | test 2 pending
2012-05-28 02:00:57	test.test	INFO	[Context: test.test:34 state: finished] Finished test: test_part12_not_an_attachment
=== (Done With Tests)

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | test 1 finished

TEST-INFO | (xpcshell/head.js) | exiting test

TEST-PASS | (xpcshell/head.js) | 326 (+ 0) check(s) passed

TEST-INFO | (xpcshell/head.js) | 0 check(s) todo
WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../../mozilla/xpcom/base/nsExceptionService.cpp, line 166
Assertion failure: !connections[i]->ConnectionReady(), at ../../../../mozilla/storage/src/mozStorageService.cpp:852
<<<<<<<
Comment 1 :aceman 2012-05-28 05:17:56 PDT
I was seeing this too, testing a debug build on Linux 32bit.
Comment 2 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-05-28 06:51:29 PDT
The db connections is being created by:


0 gloda_ds_createDB() ["resource:///modules/gloda/datastore.js":1318]
    this = [object Object]
1 gloda_ds_init() ["resource:///modules/gloda/datastore.js":1085]
    this = [object Object]
2 <TOP LEVEL> ["<unknown>":0]
    <failed to get 'this' value>
3 gloda_ns_init() ["resource:///modules/gloda/gloda.js":172]
    this = [object Object]
4 <TOP LEVEL> ["resource:///modules/gloda/gloda.js":2296]
    this = [object BackstagePass @ 0x7f5470b06470 (native @ 0x7f5473998498)]
5 <TOP LEVEL> ["<unknown>":0]
    <failed to get 'this' value>
Comment 3 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-05-28 07:16:05 PDT
Created attachment 627694 [details] [diff] [review]
call GlodaDatastore.shutdown

It looks like the problem is that GlodaDatastore.shutdown is only called from GlodaIndexer._shutdown but the test is only using the first one. A simple solution is for the test to call GlodaDatastore.shutdown.
Comment 4 Mike Conley (:mconley) - (needinfo me!) 2012-05-28 07:28:28 PDT
I can confirm that this causes our test to pass again.
Comment 5 Mark Banner (:standard8) 2012-05-28 07:29:43 PDT
Comment on attachment 627694 [details] [diff] [review]
call GlodaDatastore.shutdown

Yeah, seems reasonable. Thanks for working on this.
Comment 6 Rafael Ávila de Espíndola (:espindola) (not reading bugmail) 2012-05-28 08:15:55 PDT
https://tbpl.mozilla.org/?tree=Thunderbird-Trunk&rev=3e93bd15866e

Note You need to log in before you can comment on or make changes to this bug.