Statistics bottom dates are not displayed properly for last 365 days

VERIFIED FIXED in 2012-05-31

Status

Marketplace
Statistics
P2
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Cristian Boldan, Assigned: ngoke)

Tracking

2012-05-31
Points:
---

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created attachment 627671 [details]
statistics bottom dates

Steps to reproduce:
1. Load Statistics for an app https://marketplace-dev.allizom.org/en-US/app/lord-of-ultima-1/statistics/?last=30
2. Group by "week".
3. Select for last "365 days".
4. Group by "day".

Expected results:
Bottom dates for the last 365 days are displayed properly.

Actual results:
Bottom dates are overlayed.

Notes/Issues:
Verified on FF15 Nightly (Win 7).
Attaching screenshot for this issue.
Kevin, want to take a look?
(Assignee)

Comment 2

6 years ago
This has been fixed. Waiting on pull request.
Assignee: nobody → ngoke
OS: Windows 7 → All
Hardware: x86_64 → All
Target Milestone: --- → 2012-05-31
This is what it looks like now when grouped by day:

    http://i.imgur.com/NzaTw.png

Grouped by week:

    http://i.imgur.com/HFPuS.png

I'm of the opinion that we should delay "group by day" and "group by week" when viewing the last 365 days. We should allow only "group by month":

    http://i.imgur.com/KQYky.png
(Assignee)

Comment 4

6 years ago
I have a fix for this for group by day:

http://imgur.com/IKuaq.jpg

https://github.com/mozilla/zamboni/commit/d220b40e7506a7143b5bb8aca9531152e8a51937#L2R186

I forgot to address it for group by week.
(Reporter)

Comment 5

6 years ago
Issue is also reproducing on AMO for 365 days period when grouped by week 
https://addons-dev.allizom.org/en-US/firefox/addon/flashgot/statistics/?last=365
Attaching screenshot.
(Reporter)

Comment 6

6 years ago
Created attachment 628686 [details]
statistics bottom dates amo
Priority: -- → P2
https://github.com/mozilla/zamboni/commit/92dde38
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
Verified as fixed in https://marketplace-dev.allizom.org/en-US/app/lord-of-ultima-1/statistics/?last=365 and https://addons-dev.allizom.org/en-US/firefox/addon/firebug/statistics/?last=365 on FF15 and FF12 (Win 7)
Attaching postifx screencast.
Closing bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 9

6 years ago
Created attachment 629151 [details]
postfix statistics dates
You need to log in before you can comment on or make changes to this bug.