CSS clear doesn't work for :after pseudo element

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
4 years ago

People

(Reporter: uistler, Unassigned)

Tracking

12 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0
Build ID: 20120420145725

Steps to reproduce:

Working with markup
http://www.rageagainstw3c.ru/bugs/ff/mamanew/faq1.html
Table #content_table should be on the center. 


Folowing style doesn't clear menu items
.main-menu:after {
    clear: both;
    content: "";
    display: block;
    height: 0;
}

In mobile firefox same problem.

Screen
http://www.rageagainstw3c.ru/bugs/ff/mamanew/screen.png
Hello,

I just found your old bug-report, but I was no able to reproduce it because of missing information.
please add some more details (maybe a test case as HTML)

thank you for your help and sorry for this late answer
Flags: needinfo?(uistler)
(Reporter)

Comment 2

4 years ago
Hi.
Bug doesn't reproduce in newer versions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(uistler)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.