Port bug 723176 - support mac dmg signing in the Thunderbird system

RESOLVED FIXED in Thunderbird 15.0

Status

defect
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: standard8, Assigned: rail)

Tracking

13 Branch
Thunderbird 15.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed, thunderbird-esr10-)

Details

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #723176 +++

We're picking up support for signing Mac builds ready for 10.8. We need to port the changes from that bug ready for the automation.
In bug 730328 I prepared a draft patch in attachment 626154 [details] [diff] [review]. Still needs to be updated, see bug 723176 for the details.
Refreshed patch, still need to be tested. buildbot-configs patch incoming.
Attachment #627743 - Flags: review?
Posted patch configsSplinter Review
Attachment #627745 - Flags: review?(bhearsum)
Attachment #627743 - Flags: review? → review?(mbanner)
Attachment #627745 - Flags: review?(bhearsum) → review+
Comment on attachment 627743 [details] [diff] [review]
enable mac signing

Ok, I'm not quite sure if we should be signing Contents/Library as well, I think we can get away with it at least initially as spotlight doesn't seem to be widely used with Thunderbird.

Given this should make it better for Thunderbird on 10.8 generally, lets get it out for some testing.
Attachment #627743 - Flags: review?(mbanner) → review+
(In reply to Mark Banner (:standard8) from comment #5)
> Comment on attachment 627743 [details] [diff] [review]
> enable mac signing
> 
> Checked in:
> 
> https://hg.mozilla.org/comm-central/rev/a36e027fc622

This may cause failures until the buildbot masters have been reconfiged w/ rail's patch.
(In reply to Ben Hearsum [:bhearsum] from comment #7)
> (In reply to Mark Banner (:standard8) from comment #5)
> > Comment on attachment 627743 [details] [diff] [review]
> > enable mac signing
> > 
> > Checked in:
> > 
> > https://hg.mozilla.org/comm-central/rev/a36e027fc622
> 
> This may cause failures until the buildbot masters have been reconfiged w/
> rail's patch.

Yep, that's been done.
Trunk nightlies were fine, so we've gone ahead and landed this on branches:

https://hg.mozilla.org/releases/comm-aurora/rev/fb929f78a916
https://hg.mozilla.org/releases/comm-beta/rev/82e2188d2a1a
Assignee: nobody → rail
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0
Attachment #627743 - Flags: approval-comm-beta+
Attachment #627743 - Flags: approval-comm-aurora+
We may want this for esr, not sure yet.
Duplicate of this bug: 756994
It was decided not to take this onto esr10 - esr17 will pick it up.
You need to log in before you can comment on or make changes to this bug.