Created attachment 627752 [details] [diff] [review] v1 Bug 560009 comment 3 suggested using index_of instead of lsearch in templates for clarity.
Attachment #627752 - Flags: review?(LpSolit)
I'm not really happy to potentially break existing extensions which may use it because we simply renamed a TT function. If we changed its behavior at the same time, then why not, but here it's not the case. I agree that index_of() is much better than lsearch(), but lsearch() exists since Bugzilla 1.0! On the other hand, I don't know if this function is used a lot or not.
Severity: normal → enhancement
Should I leave lsearch as an alias for index_of for compatibility?
There is a clear consensus on IRC to not break extensions, so we won't rename this function.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.