Closed Bug 759171 Opened 10 years ago Closed 10 years ago

integrated javascript pdf viewer appears unasked and cannot be disabled

Categories

(Firefox :: Untriaged, defect)

15 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 752676

People

(Reporter: zao, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120528093039

Steps to reproduce:

I followed a link to a PDF, expecting to get a prompt to Open or Save the file.


Actual results:

The horribad pdfjs (I assume) extension opened the PDF in the browser, and has no way whatsoever to opt out or disable it.

It was bad enough when it appeared with an opt-in in the past, I sure hope that this is a bug and not intended behavior.


Expected results:

I expected the usual prompt for opening or saving the file.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 752676
pdf.js is no extension (anymore), it's the integrated into Firefox and it will become (AFAIK) the default for pdf files.
The option to disable it is bug 752676 and the duping is correct - verified dupe.
Status: RESOLVED → VERIFIED
I am not asking for an option to disable it. I'm asking why it's default-to-on without question.
>I am not asking for an option to disable it.

Your bug title was "integrated javascript pdf viewer appears unasked and *cannot be disabled*" so that certainly seemed to be part of the question.

As to why it is enabled by default: Firefox uses built-in renderers for all formats for which it has built-in support, be it HTML, JPEG or now PDF. There isn't anything special or particular about PDF in this regard.
PDFs are surely special. They are most often used for full page documents. As such they should never be drawn in too small windows.

This default is following the very bad Adobe PDF plugin way of sticking it into the browser.

Before there were frames and HTML5 wisely brings them back. A webdeveloper now has to jump through hoops to not get a PDF link in a frame rendered inside it.

It's already too late though. Back will come the days of "Why does that open so small?" questions.
You need to log in before you can comment on or make changes to this bug.