Page layout does not change to accommodate text when text size is changed

VERIFIED DUPLICATE of bug 60749

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 60749
17 years ago
17 years ago

People

(Reporter: DennyK, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Problem: Page layout elements such as spacing, table cells, link underlines, and
horizontal scroll bars do not change when the text size is changed from the View
-> Text Size menu. The page has to be refreshed in order to fix the layout.

Steps to reproduce: 
This bug can be reproduced on almost any site, but http://www.slashdot.org gives
a good demonstration of the problem.
Set Text Size to 100%
Go to http://www.slashdot.org
Change the Text Size to 50%
Notice the layout problems. Line breaks in the page display are not
redistributed, so the text now takes up half the horizontal space it used to.
The spacing between lines also grows much larger. The underlines under the links
on the page remain at their original length, even though the underlined text is
now much smaller.
Change the Text Size to 200%
Now there are some very serious display problems. Lines of text cover each other
and extend far beyond the table cells they are supposed to be contained in. Text
extends off the right side of the page, but no horizontal scroll bar appears. If
the page is scrolled, portions of the text will disappear. The amount of
disappearing text varies depending on the method used to scroll; using a mouse
wheel to scroll almost never makes the text disappear, while clicking and
dragging the scroll box will cause almost every line to experience the problem. 
Use the Reload button to refresh the page. The page layout is updated to account
for the change in text size.

Actual Results: Layout was incorrect, as described above.

Expected Results: Layout changes to incorporate the increased or decreased text
size.

Build Date/Platform: Build 2001032319 on Microsoft Windoes 98 4.10.1998

Additional Information: I've marked this bug as normal priority, because, while
the refresh solution is a fairly easy workaround, this bug could still cause
problems for users trying to change text sizes on dynamic pages or very large
HTML documents.
(Assignee)

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 60749 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Verified dupe (fixed 2001-03-25).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.