Closed Bug 759384 Opened 10 years ago Closed 10 years ago

Web Console menu item should not be checked when the Web Console is closed

Categories

(DevTools :: Console, defect)

15 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 764625

People

(Reporter: cpeterson, Unassigned)

Details

(Keywords: regression)

I have only tested Mac OS X 10.6 and 10.7.

STR:
1. Select menu item: Tools > Web Developer > Web Console
2. Close Web Console using X button or OPTION+CMD+K keyboard shortcut
3. Look at menu item again: Tools > Web Developer > Web Console

AR:
The Web Console menu item will be checked, even though the Web Console is no longer open.

ER:
The Web Console menu item should not be checked when the Web Console is not open.

I believe this bug is a regression in Nightly 2012-04-28. The pushlog regression window between builds 04-27 and 04-28 is:

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=450d8cd16316&tochange=b5c0d6abf69b

4-20 = PASS
4-25 = PASS
4-27 = PASS Built from http://hg.mozilla.org/mozilla-central/rev/450d8cd16316
4-28 = FAIL Built from http://hg.mozilla.org/mozilla-central/rev/b5c0d6abf69b
4-29 = FAIL
5-15 = FAIL
5-20 = FAIL
5-24 = FAIL
5-26 = FAIL
5-28 = FAIL
Keywords: regression
Component: Menus → Developer Tools
QA Contact: menus → developer.tools
Occurs on Linux as well 
Also occurs with Debugger menu item.
OS: Mac OS X → All
Hardware: x86 → All
Component: Developer Tools → Developer Tools: Console
QA Contact: developer.tools → developer.tools.console
Version: unspecified → 15 Branch
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 764625
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.