Nightly builds will not update properly if app.update.service.enabled doesn't exist or is set to false (always on x64, sometimes on x86)

RESOLVED FIXED in mozilla15

Status

()

Toolkit
Application Update
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: Gary King, Assigned: Away for a while)

Tracking

Trunk
mozilla15
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 628015 [details]
Nightly Update.mp4

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120529052711

Steps to reproduce:

Click on help/about Nightly/check for updates


Actual results:

I get a round spinning throbber then it updates and just hangs there


Expected results:

It should close and then update and restart.
(Reporter)

Comment 1

6 years ago
Jim Jeffery not reading bug-mail 1/2/11 <jmjeffery@embarqmail.com> changed:

Someone should, this is happening to every nightly users.

Comment 2

6 years ago
This is not happening to every nightly user. When I updated to today's build it only said "Applying Update" for a few seconds then it became a button that said "Restart to Update."
(Reporter)

Comment 3

6 years ago
You are correct Donald but either way this is not the proper behavior. If it makes you happy it is happening to more users than me.

Comment 4

6 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:15.0) Gecko/15.0 Firefox/15.0a1 ID:20120530030519

This was installed from .zip file so there's no "Mozilla Maintenance Service"[1]

On "Settings for network, updates and encryption"[2], "Check for updates, but let me choose whether to install them" is selected.

For the update today and the one yesterday this strange behavior is seen:

When I click "Nightly" > "Help" > "About Nightly" then "Check for Updates" and an update is found it is downloaded then a spinner with "Applying updates" appears and stays there (I waited for about 20 minutes but it didn't go away)

Workaround:

Close "About Nightly"
Reopen "Nightly" > "Help" > "About Nightly"
This time a button "Restart to Update" appears instead of "Applying updates" spinner

[1] https://support.mozilla.org/en-US/kb/what-mozilla-maintenance-service
[2] https://support.mozilla.org/en-US/kb/settings-network-updates-and-encryption#w_update-tab
Blocks: 307181
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: 15 Branch → Trunk
I tried with no service and the pref set to:
"Check for updates, but let me choose whether to install them"
but could not reproduce a problem.

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-05-29-03-05-18-mozilla-central/firefox-15.0a1.en-US.win32.installer.exe

I also tried with a zip build and couldn't reproduce:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-05-29-03-05-18-mozilla-central/firefox-15.0a1.en-US.win32.zip

I'm not sure what the difference is from the above people that can reproduce.
I was testing on an x86 build on a win7x64 computer.
(Assignee)

Comment 7

6 years ago
Gary, when you get to the point where the "Applying update" message appears on the screen, Can you please zip up the following folder and attach the zip file here?

C:\Users\<username>\AppData\Local\Mozilla\Firefox\<installdir>\updates

Where <username> is your computer's user name, and <installdir> is the name of the directory containing the Firefox installation, for example, if Firefox is in C:\some\path\firefox, <installdir> will be "firefox".

This will help me diagnose the problem.  Thanks!

Comment 8

6 years ago
Its happening to me, too

I have both a x32 release build (which comes which comes with its maintenance service) installed in its default of "c:\program files (x86)" and a x64 nightly build installed in its default of "c:\program files".

The x64 build is causing the problems.  Do you need any logs?
(Reporter)

Comment 9

6 years ago
Ehsan, Sorry but I cannot do that. I have since gone back to using the beta build. Firefox 15 is like a wasteland of things that break,Look at the video I have provided, this is happening.I did not make that up. This started on that day that had all of the re-spins.
(Reporter)

Comment 10

6 years ago
Maybe Kelly Cook can provide that data.
(Assignee)

Comment 11

6 years ago
(In reply to Gary King from comment #9)
> Ehsan, Sorry but I cannot do that. I have since gone back to using the beta
> build. Firefox 15 is like a wasteland of things that break,Look at the video
> I have provided, this is happening.I did not make that up. This started on
> that day that had all of the re-spins.

I do not doubt that it is happening, but without the log files, it is very hard for us to figure out what's causing it.  :-)  But it would be great if anybody experiencing this would provide us with that data.
x64 builds seems to be what's causing problems based on Comment 8.   I'll try to reproduce and report back.

Comment 13

6 years ago
Also have update problems last working one was 28th may after this trying to update to 29th may fails with the following happening:

help->about nightly

update loads 21.3 mb shows after finishing applying update then restart clicking on it causes firefox to restart but there is no more update progress window :( instead i get a UAC message for update.exe i OK this and then it tells me Software "Update Failed"

:(
Summary: Nightly will not update properly → Nightly x64 builds will not update properly after background updates

Comment 14

6 years ago
Now it shows Restart Update in about-nightly but i endup in this loop of events very bad :(
Ehsan: I can reproduce the problem no matter what the pref is for auto update or ask before.  

All you have to do to reproduce is:

1. Install this build: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2012-05-29-03-05-18-mozilla-central/firefox-15.0a1.en-US.win64-x86_64.installer.exe
2. Do an upgrade

Actual results:
It hangs on applying.

Expected results:
The update applies.

Other notes:
This happens whether or not you have the service installed.  Please note that x64 builds do not use the service at all because it never writes pending-service.
(Reporter)

Comment 16

6 years ago
To comment 14- That is what was happening to me. I used a Win32 Build on a Win 7 x64
(Assignee)

Comment 17

6 years ago
Filed bug 759777 to get the Windows x64 nightly updates disabled for now.
(Reporter)

Comment 18

6 years ago
Ehsan this also is happening with win 32 builds.
Component: Untriaged → Application Update
Product: Firefox → Toolkit
QA Contact: untriaged → application.update
Target Milestone: --- → mozilla15
Gary King, I just noticed your user agent does contain WOW64.  Since we have consistent steps to reproduce with an x64 build let's find the solution to that, it might be the same cause as what you are getting.  If not we'll post a new bug for the x86 build problem.

Comment 20

6 years ago
This is 32 bit version now it goes totaly whacky showing Applying update... and spins to death :(

Comment 21

6 years ago
i saw it creates a updater folder and inside are some 0 byte tmp files is this normal ?
Summary: Nightly x64 builds will not update properly after background updates → Nightly x64 builds will not update properly after background updates (and sometimes x86 builds)

Comment 22

6 years ago
The old progress window update without UAC message worked always reliable why changing this now into this ?
(Assignee)

Comment 23

6 years ago
(In reply to CruNcher from comment #21)
> i saw it creates a updater folder and inside are some 0 byte tmp files is
> this normal ?

No.  Can you please file a new bug and provide the information I requested in comment 7?
(Assignee)

Updated

6 years ago
Assignee: nobody → ehsan

Comment 24

6 years ago
Ok now Eset Smart Security showed that the Hash of Firefox.exe was changed and wanted me to agree (normaly this is ok) i agreed and it started but the date of Firefox is still 28th May what is going on ?
(Reporter)

Comment 25

6 years ago
to comment 19. I am now using Beta 13 Build 6 and I looked in C:\Users\<username>\AppData\Local\Mozilla\Firefox\<installdir>\updates
Probably do to the fact that I have not updated anything. This also does NOT update properly as reported in my original Bug in Win 32 builds at least on Win 7 64Bit.

Look at the video.This happens on Win 32 Builds as well and often every day. If it did not, I would not have filed a report. Now you go and change it to appear that it is only sometimes affects Win 32.Please read comment 20.
(Assignee)

Comment 26

6 years ago
(In reply to CruNcher from comment #24)
> Ok now Eset Smart Security showed that the Hash of Firefox.exe was changed
> and wanted me to agree (normaly this is ok) i agreed and it started but the
> date of Firefox is still 28th May what is going on ?

Please file a new bug, and we'll discuss it there.  The issue you're seeing is probably different.
(Assignee)

Comment 27

6 years ago
(In reply to Gary King from comment #25)
> to comment 19. I am now using Beta 13 Build 6 and I looked in
> C:\Users\<username>\AppData\Local\Mozilla\Firefox\<installdir>\updates
> Probably do to the fact that I have not updated anything. This also does NOT
> update properly as reported in my original Bug in Win 32 builds at least on
> Win 7 64Bit.

If you also cannot update a Beta 13 build, there's probably something else involved here as well.  You should not see the "Applying updates..." string in the About dialog at all in Firefox 13, as bug 307181 has only landed on Nightly.

> Look at the video.This happens on Win 32 Builds as well and often every day.
> If it did not, I would not have filed a report. Now you go and change it to
> appear that it is only sometimes affects Win 32.Please read comment 20.

I changed the summary if that makes you happy.  We managed to reproduce this on a Win64 build, and that enables us to actually fix the problem.  Without any more information from your side, it is impossible to know whether the problem we're seeing is the same as the one you're seeing.
Summary: Nightly x64 builds will not update properly after background updates (and sometimes x86 builds) → Nightly builds will not update properly after background updates
(Reporter)

Comment 28

6 years ago
The wonder you people never get anything fixed, it takes you days to accept the fact that there even is a bug. Now you want Cruncher to file a new bug on the same problem that I filed it on. Why did you change my bug in the first place? Cruncher you can use my video if you want. Some of you devs discuss me.
Summary: Nightly builds will not update properly after background updates → Nightly x64 builds will not update properly after background updates (and sometimes x86 builds)

Comment 29

6 years ago
this is funny

Begin moving sourceDir (C:\Program Files (x86)\firefox10) to tmpDir (C:\Program Files (x86)\firefox10.bak)
rename_file: proceeding to rename the directory
rename_file: failed to rename file - src: C:\Program Files (x86)\firefox10, dst:C:\Program Files (x86)\firefox10.bak, err: 13
Moving sourceDir to tmpDir failed, err: 7
failed: 7

i agreed to the UAC message ?
(Reporter)

Updated

6 years ago
Summary: Nightly x64 builds will not update properly after background updates (and sometimes x86 builds) → Nightly x32 builds will not update properly after background updates (and sometimes x64 builds)

Comment 30

6 years ago
Performing a replace request
Could not disable token privilege value: SeAssignPrimaryTokenPrivilege. (1300)
Could not disable token privilege value: SeAuditPrivilege. (1300)
Disabled unneeded token privilege: SeBackupPrivilege.
Disabled unneeded token privilege: SeCreateGlobalPrivilege.
Disabled unneeded token privilege: SeCreatePagefilePrivilege.
Could not disable token privilege value: SeCreatePermanentPrivilege. (1300)
Disabled unneeded token privilege: SeCreateSymbolicLinkPrivilege.
Could not disable token privilege value: SeCreateTokenPrivilege. (1300)
Disabled unneeded token privilege: SeDebugPrivilege.
Could not disable token privilege value: SeEnableDelegationPrivilege. (1300)
Disabled unneeded token privilege: SeImpersonatePrivilege.
Disabled unneeded token privilege: SeIncreaseBasePriorityPrivilege.
Disabled unneeded token privilege: SeIncreaseQuotaPrivilege.
Disabled unneeded token privilege: SeIncreaseWorkingSetPrivilege.
Disabled unneeded token privilege: SeLoadDriverPrivilege.
Disabled unneeded token privilege: SeLockMemoryPrivilege.
Could not disable token privilege value: SeMachineAccountPrivilege. (1300)
Disabled unneeded token privilege: SeManageVolumePrivilege.
Disabled unneeded token privilege: SeProfileSingleProcessPrivilege.
Could not disable token privilege value: SeRelabelPrivilege. (1300)
Disabled unneeded token privilege: SeRemoteShutdownPrivilege.
Disabled unneeded token privilege: SeRestorePrivilege.
Disabled unneeded token privilege: SeSecurityPrivilege.
Disabled unneeded token privilege: SeShutdownPrivilege.
Could not disable token privilege value: SeSyncAgentPrivilege. (1300)
Disabled unneeded token privilege: SeSystemEnvironmentPrivilege.
Disabled unneeded token privilege: SeSystemProfilePrivilege.
Disabled unneeded token privilege: SeSystemtimePrivilege.
Disabled unneeded token privilege: SeTakeOwnershipPrivilege.
Could not disable token privilege value: SeTcbPrivilege. (1300)
Disabled unneeded token privilege: SeTimeZonePrivilege.
Could not disable token privilege value: SeTrustedCredManAccessPrivilege. (1300)
Disabled unneeded token privilege: SeUndockPrivilege.
Could not disable token privilege value: SeUnsolicitedInputPrivilege. (1313)
SOURCE DIRECTORY C:\Users\CruNcher\AppData\Local\Mozilla\Firefox\firefox10\updates\0
DESTINATION DIRECTORY C:\Program Files (x86)\firefox10\updated
Begin moving sourceDir (C:\Program Files (x86)\firefox10) to tmpDir (C:\Program Files (x86)\firefox10.bak)
rename_file: proceeding to rename the directory
rename_file: failed to rename file - src: C:\Program Files (x86)\firefox10, dst:C:\Program Files (x86)\firefox10.bak, err: 13
Moving sourceDir to tmpDir failed, err: 7
failed: 7
calling QuitProgressUI
Performing a replace request

Comment 31

6 years ago
Performing a background update
SOURCE DIRECTORY C:\Users\CruNcher\AppData\Local\Mozilla\Firefox\firefox10\updates\0
DESTINATION DIRECTORY C:\Program Files (x86)\firefox10\updated
UPDATE TYPE complete
PREPARE REMOVEFILE xul.dll
PREPARE REMOVEFILE xpcom.dll
PREPARE REMOVEFILE webapprt/webapprt.ini
PREPARE REMOVEFILE webapprt/omni.ja
PREPARE REMOVEFILE webapprt-stub.exe
PREPARE REMOVEFILE webapp-uninstaller.exe
PREPARE REMOVEFILE updater.ini
PREPARE REMOVEFILE updater.exe
PREPARE REMOVEFILE update-settings.ini
PREPARE REMOVEFILE uninstall/helper.exe
PREPARE REMOVEFILE ssl3.dll
PREPARE REMOVEFILE softokn3.dll
PREPARE REMOVEFILE softokn3.chk
PREPARE REMOVEFILE smime3.dll
PREPARE REMOVEFILE searchplugins/yahoo.xml
PREPARE REMOVEFILE searchplugins/wikipedia.xml
PREPARE REMOVEFILE searchplugins/twitter.xml
PREPARE REMOVEFILE searchplugins/google.xml
PREPARE REMOVEFILE searchplugins/eBay.xml
PREPARE REMOVEFILE searchplugins/bing.xml
PREPARE REMOVEFILE searchplugins/amazondotcom.xml
PREPARE REMOVEFILE removed-files
PREPARE REMOVEFILE plugin-container.exe
PREPARE REMOVEFILE plds4.dll
PREPARE REMOVEFILE plc4.dll
PREPARE REMOVEFILE platform.ini
PREPARE REMOVEFILE omni.ja
PREPARE REMOVEFILE nssutil3.dll
PREPARE REMOVEFILE nssdbm3.dll
PREPARE REMOVEFILE nssdbm3.chk
PREPARE REMOVEFILE nssckbi.dll
PREPARE REMOVEFILE nss3.dll
PREPARE REMOVEFILE nspr4.dll
PREPARE REMOVEFILE msvcr100.dll
PREPARE REMOVEFILE msvcp100.dll
PREPARE REMOVEFILE mozsqlite3.dll
PREPARE REMOVEFILE mozjs.dll
PREPARE REMOVEFILE mozglue.dll
PREPARE REMOVEFILE mozalloc.dll
PREPARE REMOVEFILE maintenanceservice_installer.exe
PREPARE REMOVEFILE maintenanceservice.exe
PREPARE REMOVEFILE libGLESv2.dll
PREPARE REMOVEFILE libEGL.dll
PREPARE REMOVEFILE gkmedias.dll
PREPARE REMOVEFILE freebl3.dll
PREPARE REMOVEFILE freebl3.chk
PREPARE REMOVEFILE firefox.exe
PREPARE REMOVEFILE dictionaries/en-US.dic
PREPARE REMOVEFILE dictionaries/en-US.aff
PREPARE REMOVEFILE dependentlibs.list
PREPARE REMOVEFILE d3dx9_43.dll
PREPARE REMOVEFILE crashreporter.ini
PREPARE REMOVEFILE crashreporter.exe
PREPARE REMOVEFILE crashreporter-override.ini
PREPARE REMOVEFILE components/browsercomps.dll
PREPARE REMOVEFILE components/binary.manifest
PREPARE REMOVEFILE chrome.manifest
PREPARE REMOVEFILE blocklist.xml
PREPARE REMOVEFILE application.ini
PREPARE REMOVEFILE D3DCompiler_43.dll
PREPARE REMOVEFILE AccessibleMarshal.dll
PREPARE REMOVEDIR webapprt/
PREPARE REMOVEDIR uninstall/
PREPARE REMOVEDIR searchplugins/
PREPARE REMOVEDIR dictionaries/
PREPARE REMOVEDIR defaults/
PREPARE REMOVEDIR components/
PREPARE ADD xul.dll
PREPARE ADD xpcom.dll
PREPARE ADD webapprt/webapprt.ini
PREPARE ADD webapprt/omni.ja
PREPARE ADD webapprt-stub.exe
PREPARE ADD webapp-uninstaller.exe
PREPARE ADD updater.ini
PREPARE ADD updater.exe
PREPARE ADD update-settings.ini
PREPARE ADD uninstall/helper.exe
PREPARE ADD ssl3.dll
PREPARE ADD softokn3.dll
PREPARE ADD softokn3.chk
PREPARE ADD smime3.dll
PREPARE ADD searchplugins/yahoo.xml
PREPARE ADD searchplugins/wikipedia.xml
PREPARE ADD searchplugins/twitter.xml
PREPARE ADD searchplugins/google.xml
PREPARE ADD searchplugins/eBay.xml
PREPARE ADD searchplugins/bing.xml
PREPARE ADD searchplugins/amazondotcom.xml
PREPARE ADD removed-files
PREPARE ADD precomplete
PREPARE ADD plugin-container.exe
PREPARE ADD plds4.dll
PREPARE ADD plc4.dll
PREPARE ADD platform.ini
PREPARE ADD omni.ja
PREPARE ADD nssutil3.dll
PREPARE ADD nssdbm3.dll
PREPARE ADD nssdbm3.chk
PREPARE ADD nssckbi.dll
PREPARE ADD nss3.dll
PREPARE ADD nspr4.dll
PREPARE ADD msvcr100.dll
PREPARE ADD msvcp100.dll
PREPARE ADD mozsqlite3.dll
PREPARE ADD mozjs.dll
PREPARE ADD mozglue.dll
PREPARE ADD mozalloc.dll
PREPARE ADD maintenanceservice_installer.exe
PREPARE ADD maintenanceservice.exe
PREPARE ADD libGLESv2.dll
PREPARE ADD libEGL.dll
PREPARE ADD gkmedias.dll
PREPARE ADD freebl3.dll
PREPARE ADD freebl3.chk
PREPARE ADD firefox.exe
PREPARE ADD extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
PREPARE ADD extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/icon.png
PREPARE ADD dictionaries/en-US.dic
PREPARE ADD dictionaries/en-US.aff
PREPARE ADD dependentlibs.list
PREPARE ADD d3dx9_43.dll
PREPARE ADD crashreporter.ini
PREPARE ADD crashreporter.exe
PREPARE ADD crashreporter-override.ini
PREPARE ADD components/browsercomps.dll
PREPARE ADD components/binary.manifest
PREPARE ADD chrome.manifest
PREPARE ADD blocklist.xml
PREPARE ADD application.ini
PREPARE ADD D3DCompiler_43.dll
PREPARE ADD AccessibleMarshal.dll
EXECUTE REMOVEFILE xul.dll
EXECUTE REMOVEFILE xpcom.dll
EXECUTE REMOVEFILE webapprt/webapprt.ini
EXECUTE REMOVEFILE webapprt/omni.ja
EXECUTE REMOVEFILE webapprt-stub.exe
EXECUTE REMOVEFILE webapp-uninstaller.exe
EXECUTE REMOVEFILE updater.ini
EXECUTE REMOVEFILE updater.exe
EXECUTE REMOVEFILE update-settings.ini
EXECUTE REMOVEFILE uninstall/helper.exe
EXECUTE REMOVEFILE ssl3.dll
EXECUTE REMOVEFILE softokn3.dll
EXECUTE REMOVEFILE softokn3.chk
EXECUTE REMOVEFILE smime3.dll
EXECUTE REMOVEFILE searchplugins/yahoo.xml
EXECUTE REMOVEFILE searchplugins/wikipedia.xml
EXECUTE REMOVEFILE searchplugins/twitter.xml
EXECUTE REMOVEFILE searchplugins/google.xml
EXECUTE REMOVEFILE searchplugins/eBay.xml
EXECUTE REMOVEFILE searchplugins/bing.xml
EXECUTE REMOVEFILE searchplugins/amazondotcom.xml
EXECUTE REMOVEFILE removed-files
EXECUTE REMOVEFILE plugin-container.exe
EXECUTE REMOVEFILE plds4.dll
EXECUTE REMOVEFILE plc4.dll
EXECUTE REMOVEFILE platform.ini
EXECUTE REMOVEFILE omni.ja
EXECUTE REMOVEFILE nssutil3.dll
EXECUTE REMOVEFILE nssdbm3.dll
EXECUTE REMOVEFILE nssdbm3.chk
EXECUTE REMOVEFILE nssckbi.dll
EXECUTE REMOVEFILE nss3.dll
EXECUTE REMOVEFILE nspr4.dll
EXECUTE REMOVEFILE msvcr100.dll
EXECUTE REMOVEFILE msvcp100.dll
EXECUTE REMOVEFILE mozsqlite3.dll
EXECUTE REMOVEFILE mozjs.dll
EXECUTE REMOVEFILE mozglue.dll
EXECUTE REMOVEFILE mozalloc.dll
EXECUTE REMOVEFILE maintenanceservice_installer.exe
EXECUTE REMOVEFILE maintenanceservice.exe
EXECUTE REMOVEFILE libGLESv2.dll
EXECUTE REMOVEFILE libEGL.dll
EXECUTE REMOVEFILE gkmedias.dll
EXECUTE REMOVEFILE freebl3.dll
EXECUTE REMOVEFILE freebl3.chk
EXECUTE REMOVEFILE firefox.exe
EXECUTE REMOVEFILE dictionaries/en-US.dic
EXECUTE REMOVEFILE dictionaries/en-US.aff
EXECUTE REMOVEFILE dependentlibs.list
EXECUTE REMOVEFILE d3dx9_43.dll
EXECUTE REMOVEFILE crashreporter.ini
EXECUTE REMOVEFILE crashreporter.exe
EXECUTE REMOVEFILE crashreporter-override.ini
EXECUTE REMOVEFILE components/browsercomps.dll
EXECUTE REMOVEFILE components/binary.manifest
EXECUTE REMOVEFILE chrome.manifest
EXECUTE REMOVEFILE blocklist.xml
EXECUTE REMOVEFILE application.ini
EXECUTE REMOVEFILE D3DCompiler_43.dll
EXECUTE REMOVEFILE AccessibleMarshal.dll
EXECUTE REMOVEDIR webapprt/
EXECUTE REMOVEDIR uninstall/
EXECUTE REMOVEDIR searchplugins/
EXECUTE REMOVEDIR dictionaries/
EXECUTE REMOVEDIR defaults/
EXECUTE REMOVEDIR components/
EXECUTE ADD xul.dll
EXECUTE ADD xpcom.dll
EXECUTE ADD webapprt/webapprt.ini
EXECUTE ADD webapprt/omni.ja
EXECUTE ADD webapprt-stub.exe
EXECUTE ADD webapp-uninstaller.exe
EXECUTE ADD updater.ini
EXECUTE ADD updater.exe
EXECUTE ADD update-settings.ini
EXECUTE ADD uninstall/helper.exe
EXECUTE ADD ssl3.dll
EXECUTE ADD softokn3.dll
EXECUTE ADD softokn3.chk
EXECUTE ADD smime3.dll
EXECUTE ADD searchplugins/yahoo.xml
EXECUTE ADD searchplugins/wikipedia.xml
EXECUTE ADD searchplugins/twitter.xml
EXECUTE ADD searchplugins/google.xml
EXECUTE ADD searchplugins/eBay.xml
EXECUTE ADD searchplugins/bing.xml
EXECUTE ADD searchplugins/amazondotcom.xml
EXECUTE ADD removed-files
EXECUTE ADD precomplete
EXECUTE ADD plugin-container.exe
EXECUTE ADD plds4.dll
EXECUTE ADD plc4.dll
EXECUTE ADD platform.ini
EXECUTE ADD omni.ja
EXECUTE ADD nssutil3.dll
EXECUTE ADD nssdbm3.dll
EXECUTE ADD nssdbm3.chk
EXECUTE ADD nssckbi.dll
EXECUTE ADD nss3.dll
EXECUTE ADD nspr4.dll
EXECUTE ADD msvcr100.dll
EXECUTE ADD msvcp100.dll
EXECUTE ADD mozsqlite3.dll
EXECUTE ADD mozjs.dll
EXECUTE ADD mozglue.dll
EXECUTE ADD mozalloc.dll
EXECUTE ADD maintenanceservice_installer.exe
EXECUTE ADD maintenanceservice.exe
EXECUTE ADD libGLESv2.dll
EXECUTE ADD libEGL.dll
EXECUTE ADD gkmedias.dll
EXECUTE ADD freebl3.dll
EXECUTE ADD freebl3.chk
EXECUTE ADD firefox.exe
EXECUTE ADD extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
EXECUTE ADD extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/icon.png
EXECUTE ADD dictionaries/en-US.dic
EXECUTE ADD dictionaries/en-US.aff
EXECUTE ADD dependentlibs.list
EXECUTE ADD d3dx9_43.dll
EXECUTE ADD crashreporter.ini
EXECUTE ADD crashreporter.exe
EXECUTE ADD crashreporter-override.ini
EXECUTE ADD components/browsercomps.dll
EXECUTE ADD components/binary.manifest
EXECUTE ADD chrome.manifest
EXECUTE ADD blocklist.xml
EXECUTE ADD application.ini
EXECUTE ADD D3DCompiler_43.dll
EXECUTE ADD AccessibleMarshal.dll
FINISH REMOVEFILE xul.dll
FINISH REMOVEFILE xpcom.dll
FINISH REMOVEFILE webapprt/webapprt.ini
FINISH REMOVEFILE webapprt/omni.ja
FINISH REMOVEFILE webapprt-stub.exe
FINISH REMOVEFILE webapp-uninstaller.exe
FINISH REMOVEFILE updater.ini
FINISH REMOVEFILE updater.exe
FINISH REMOVEFILE update-settings.ini
FINISH REMOVEFILE uninstall/helper.exe
FINISH REMOVEFILE ssl3.dll
FINISH REMOVEFILE softokn3.dll
FINISH REMOVEFILE softokn3.chk
FINISH REMOVEFILE smime3.dll
FINISH REMOVEFILE searchplugins/yahoo.xml
FINISH REMOVEFILE searchplugins/wikipedia.xml
FINISH REMOVEFILE searchplugins/twitter.xml
FINISH REMOVEFILE searchplugins/google.xml
FINISH REMOVEFILE searchplugins/eBay.xml
FINISH REMOVEFILE searchplugins/bing.xml
FINISH REMOVEFILE searchplugins/amazondotcom.xml
FINISH REMOVEFILE removed-files
FINISH REMOVEFILE plugin-container.exe
FINISH REMOVEFILE plds4.dll
FINISH REMOVEFILE plc4.dll
FINISH REMOVEFILE platform.ini
FINISH REMOVEFILE omni.ja
FINISH REMOVEFILE nssutil3.dll
FINISH REMOVEFILE nssdbm3.dll
FINISH REMOVEFILE nssdbm3.chk
FINISH REMOVEFILE nssckbi.dll
FINISH REMOVEFILE nss3.dll
FINISH REMOVEFILE nspr4.dll
FINISH REMOVEFILE msvcr100.dll
FINISH REMOVEFILE msvcp100.dll
FINISH REMOVEFILE mozsqlite3.dll
FINISH REMOVEFILE mozjs.dll
FINISH REMOVEFILE mozglue.dll
FINISH REMOVEFILE mozalloc.dll
FINISH REMOVEFILE maintenanceservice_installer.exe
FINISH REMOVEFILE maintenanceservice.exe
FINISH REMOVEFILE libGLESv2.dll
FINISH REMOVEFILE libEGL.dll
FINISH REMOVEFILE gkmedias.dll
FINISH REMOVEFILE freebl3.dll
FINISH REMOVEFILE freebl3.chk
FINISH REMOVEFILE firefox.exe
FINISH REMOVEFILE dictionaries/en-US.dic
FINISH REMOVEFILE dictionaries/en-US.aff
FINISH REMOVEFILE dependentlibs.list
FINISH REMOVEFILE d3dx9_43.dll
FINISH REMOVEFILE crashreporter.ini
FINISH REMOVEFILE crashreporter.exe
FINISH REMOVEFILE crashreporter-override.ini
FINISH REMOVEFILE components/browsercomps.dll
FINISH REMOVEFILE components/binary.manifest
FINISH REMOVEFILE chrome.manifest
FINISH REMOVEFILE blocklist.xml
FINISH REMOVEFILE application.ini
FINISH REMOVEFILE D3DCompiler_43.dll
FINISH REMOVEFILE AccessibleMarshal.dll
FINISH REMOVEDIR webapprt/
non-fatal error removing directory: webapprt/, rv: 0, err: 41
FINISH REMOVEDIR uninstall/
non-fatal error removing directory: uninstall/, rv: 0, err: 41
FINISH REMOVEDIR searchplugins/
non-fatal error removing directory: searchplugins/, rv: 0, err: 41
FINISH REMOVEDIR dictionaries/
non-fatal error removing directory: dictionaries/, rv: 0, err: 41
FINISH REMOVEDIR defaults/
non-fatal error removing directory: defaults/, rv: 0, err: 41
FINISH REMOVEDIR components/
non-fatal error removing directory: components/, rv: 0, err: 41
FINISH ADD xul.dll
FINISH ADD xpcom.dll
FINISH ADD webapprt/webapprt.ini
FINISH ADD webapprt/omni.ja
FINISH ADD webapprt-stub.exe
FINISH ADD webapp-uninstaller.exe
FINISH ADD updater.ini
FINISH ADD updater.exe
FINISH ADD update-settings.ini
FINISH ADD uninstall/helper.exe
FINISH ADD ssl3.dll
FINISH ADD softokn3.dll
FINISH ADD softokn3.chk
FINISH ADD smime3.dll
FINISH ADD searchplugins/yahoo.xml
FINISH ADD searchplugins/wikipedia.xml
FINISH ADD searchplugins/twitter.xml
FINISH ADD searchplugins/google.xml
FINISH ADD searchplugins/eBay.xml
FINISH ADD searchplugins/bing.xml
FINISH ADD searchplugins/amazondotcom.xml
FINISH ADD removed-files
FINISH ADD precomplete
FINISH ADD plugin-container.exe
FINISH ADD plds4.dll
FINISH ADD plc4.dll
FINISH ADD platform.ini
FINISH ADD omni.ja
FINISH ADD nssutil3.dll
FINISH ADD nssdbm3.dll
FINISH ADD nssdbm3.chk
FINISH ADD nssckbi.dll
FINISH ADD nss3.dll
FINISH ADD nspr4.dll
FINISH ADD msvcr100.dll
FINISH ADD msvcp100.dll
FINISH ADD mozsqlite3.dll
FINISH ADD mozjs.dll
FINISH ADD mozglue.dll
FINISH ADD mozalloc.dll
FINISH ADD maintenanceservice_installer.exe
FINISH ADD maintenanceservice.exe
FINISH ADD libGLESv2.dll
FINISH ADD libEGL.dll
FINISH ADD gkmedias.dll
FINISH ADD freebl3.dll
FINISH ADD freebl3.chk
FINISH ADD firefox.exe
FINISH ADD extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
FINISH ADD extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/icon.png
FINISH ADD dictionaries/en-US.dic
FINISH ADD dictionaries/en-US.aff
FINISH ADD dependentlibs.list
FINISH ADD d3dx9_43.dll
FINISH ADD crashreporter.ini
FINISH ADD crashreporter.exe
FINISH ADD crashreporter-override.ini
FINISH ADD components/browsercomps.dll
FINISH ADD components/binary.manifest
FINISH ADD chrome.manifest
FINISH ADD blocklist.xml
FINISH ADD application.ini
FINISH ADD D3DCompiler_43.dll
FINISH ADD AccessibleMarshal.dll
succeeded
calling QuitProgressUI
(Reporter)

Comment 32

6 years ago
To comment 27, I am not trying to update a Beta build. Do you people even read these comments? What part of I am now using Firefox 13 Beta 6 don't you understand.I was asked by one of you people that I may still be able to help.
(Assignee)

Comment 33

6 years ago
OK, I figured out why the bug happens.  If the service is disabled, we'll hit this code <http://mxr.mozilla.org/mozilla-central/source/toolkit/mozapps/update/nsUpdateService.js#440>, which fails here: <http://mxr.mozilla.org/mozilla-central/source/xpcom/io/nsLocalFileWin.cpp#1362>.

And this indeed affects both x86 and x64 builds if the maintenance service is disabled.

I'll submit a patch shortly.
Summary: Nightly x32 builds will not update properly after background updates (and sometimes x64 builds) → Nightly builds will not update properly after background updates if the maintenance service is disabled
(Reporter)

Comment 34

6 years ago
My maintenance service was NOT disabled. The patch that you submit will be useless!

Comment 35

6 years ago
I guess he means the fix for my problem i guess they are slightly different but yeah i don't want another service on my system especially not one that fiddles around so deep and changes security related stuff.

Comment 36

6 years ago
even if that means slow startup time and manual updating ;)

Comment 37

6 years ago
I have a very precise reasoning about these service update stuff and no 3rd party should be allowed todo it neither Adobe nor Google nor Mozilla without Microsoft creating a API for 3rd parties arround this with 1 unique update place. Never ever i gonna flood my system with 3rd party service code never.
(Reporter)

Comment 38

6 years ago
I find it funny that I started this bug report and have changed it's name once and now they are fixing something that is not broken. I object strenuously for the spamming of my bug report. Please center it back to what was reported. If you want another bug to play with file one, do not mess mine up. This is to Ehsan!
(Reporter)

Updated

6 years ago
Alias: Win
Summary: Nightly builds will not update properly after background updates if the maintenance service is disabled → Win 32 Nightly builds will not update properly and Win 64 Bit build (sometimes)
Gary to ensure that Ehsan's fix is the same as your problem could you check the following for me?

1. Go to about:config
2. I the Search: box please enter: app.update.service.enabled
3. Please note in this bug what the value is for app.update.service.enabled


Thanks!
(Reporter)

Comment 40

6 years ago
No it is not, it is set to false and always has been.
So I can confirm that the fix Ehsan is proposing will likely fix your problem.

In particular the bug that Ehsan found will only happen when:
i) app.update.service.enabled doesn't exist
or
ii) app.update.service.enabled is set to false.

On x64 builds i) is always true and hence why x64 builds can always reproduce it.
On most installs they have app.update.service.enabled and it is set to true even when the service is uninstalled.   The reason I couldn't reproduce earlier is because I had app.update.service.enabled set to true even know my service was uninstalled.
Summary: Win 32 Nightly builds will not update properly and Win 64 Bit build (sometimes) → Nightly builds will not update properly if app.update.service.enabled doesn't exist or is set to false (always on x64, sometimes on x86)
(Reporter)

Comment 42

6 years ago
so then you are saying that all I have to do is re install yesterday build of 15 and change this app.update.service.enabled is set to True that all of my updates will work as designed. Even with a service in MS that I do not need nor want.
Re  CruNcher:
> I have a very precise reasoning about these service update stuff and no 3rd 
> party should be allowed todo it neither Adobe nor Google nor Mozilla 
> without Microsoft creating a API for 3rd parties arround this with 1 
> unique update place. Never ever i gonna flood my system with 3rd party 
> service code never.

You have the right to feel this way and the right to uninstall this optional component.  But this bug is not related to that and so it's not the best place to discuss it.  I think a mozillazine forum would be a better place for this discussion.

Thanks for your help and information in the bug by the way.
Re Gary King:

> so then you are saying that all I have to do is re install yesterday build of 
> 15 and change this app.update.service.enabled is set to True that all of 
> my updates will work as designed. Even with a service in MS that I do not 
> need nor want.

I'm saying you can set the said value to true in about:config and it'll work whether or not you have the service installed.  The bug is being patched and will be fixed soon.  Thanks again for your help in troubleshooting this issue.
(Reporter)

Comment 45

6 years ago
Will this patch be in tonight's  build?
Possibly but you will need to have that pref set to true in the build you are currently running that has to update to the newer build, so I suggest to set it to true for now even if you have the service uninstalled. 

Also it would be good for you to check to make sure the upgrade works after that.  That way we know with complete certainty that this fix is an exact match for your bug report.
(Reporter)

Comment 47

6 years ago
Will do.
I think we hit the same issue today with our mozmill update test on Windows Vista:
http://mozmill-ci.blargon7.com/#/update/report/fdec829b93b19c73985be1d3882d773d

Strangely the same failure is also shown for Linux builds:
http://mozmill-ci.blargon7.com/#/update/report/fdec829b93b19c73985be1d3882b3aa6

Not sure how it is related to this bug or if it still takes longer than 60s on linux to apply the update. But that sounds awkward too.
(Assignee)

Comment 49

6 years ago
(In reply to Henrik Skupin (:whimboo) from comment #48)
> I think we hit the same issue today with our mozmill update test on Windows
> Vista:
> http://mozmill-ci.blargon7.com/#/update/report/
> fdec829b93b19c73985be1d3882d773d
> 
> Strangely the same failure is also shown for Linux builds:
> http://mozmill-ci.blargon7.com/#/update/report/
> fdec829b93b19c73985be1d3882b3aa6
> 
> Not sure how it is related to this bug or if it still takes longer than 60s
> on linux to apply the update. But that sounds awkward too.

It is possible that is the same bug as this one, yes.
(Assignee)

Comment 50

6 years ago
Created attachment 628389 [details] [diff] [review]
Patch (v1)

When I tried to test this patch locally, no matter what I did I couldn't get any changes to my nsUpdateService.js file reflected in what actually gets run, so I pushed to the Oak branch and will test this before pushing there.  But the patch is pretty simple, it basically avoids passing ".." to the nsIFile::Append.
Attachment #628389 - Flags: review?(robert.bugzilla)
(Reporter)

Comment 51

6 years ago
Now after i re installed the Nightly build of 29 May 2012 and set everything correctly I found that i=Nightly will not update at all. See video.

http://s20.photobucket.com/albums/b243/TK-1913/?action=view&current=NightlyWillnotupdate.mp4

I am about to send this entire bug to Lewis Black as he could write a very good comedy bit about it.

[b]Do you have updates turned off?[/b]
(Reporter)

Comment 52

6 years ago
I can now provide data from my side once again
Please see Bug 759777, updates were disabled temporarily until a fix for this lands.
(Reporter)

Comment 54

6 years ago
Could you turn in back on for about 10 minutes?
It'll be easiest to just wait until the patch lands and then you can try with the pref set on.  I'm almost certain the proposed fix is your problem anyway based on the previous data you sent in.
(Reporter)

Comment 56

6 years ago
OK, I will just download the build from 30 May 2012

Comment 57

6 years ago
Did you also disabled 32bits update as their is also no 32bit update anymore offered it says Nightly is up to date with the 28th may build :(
Yup both x64 and x86, please see: Bug 759777 Comment 4

Comment 59

6 years ago
Thx Brian btw for me app.update.service.enabled is true (i looked) and it failed anyways with the above logged loop behaviour (only the service is not running) Win 7 64 bit. Also the update process confused Eset Smart Security somehow which believed the firefox.exe was changed (it checks the hash of changed executables on runtime) as it recorded the /updated/firefox.exe for the firefox.exe in the main path.
Comment on attachment 628389 [details] [diff] [review]
Patch (v1)

Can you verify this on oak before nightly updates are turned back on?
Attachment #628389 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 61

6 years ago
(In reply to Robert Strong [:rstrong] (do not email) from comment #60)
> Comment on attachment 628389 [details] [diff] [review]
> Patch (v1)
> 
> Can you verify this on oak before nightly updates are turned back on?

For sure.  But I'll land on mozilla-central in the mean time as the Windows builds take quite a while.
(Assignee)

Comment 62

6 years ago
https://hg.mozilla.org/mozilla-central/rev/e89ed404ebe5

I'll file a releng bug to re-enable nightlies once I've verified this fix on the Oak branch.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 63

6 years ago
I verified that this patch fixes this bug for both x86 and x64 builds on the Oak branch.
(Assignee)

Updated

6 years ago
Depends on: 759935
(Assignee)

Comment 64

6 years ago
Filed bug 759935 to re-enable Windows nightly updates.
(Reporter)

Comment 65

6 years ago
There is a re spin and I cannot get it plus 2 more on the way
(Assignee)

Updated

6 years ago
Alias: Win
(Reporter)

Comment 66

6 years ago
Thank you for all of your helo, I was able to get the re-spins.
(Reporter)

Comment 67

6 years ago
Thank you for all of your[b] help,[/b]  I was able to get the re-spins

Comment 68

6 years ago
Update still fails ffrom the 28th may for me UAC message (with the updater/firefox.exe replace firefox.exe) i push yes and then http://img801.imageshack.us/img801/8292/updatefail.png

Comment 69

6 years ago
So i have several choices now i ignore it and update manually and hope nobody else is going to experience this anymore or i try to fix this with you guys so that it updates properly from this 28th may build based on my config (i really don't see why it shouldn't or does the updater.exe doesn't get replaced via the update and i have still the wrong behaving one from the 28th may build which tries to update and fails), it might be of course that after updating manually it will happen again the next update cycle though (unless the updater.exe gets replaced with the fixed one).

I guess i go with option 2 and see if it happens the next update cycle again if it does i gonna fill a explicit report about this.

Comment 70

6 years ago
So in clear text should i need to update manually for it to work or should it normally update now, and that it fails is still strange ;) ?
CruNcher, I suspected your issue was different from Comment 30.  Could you verify that there are no other processes running in task manager with firefox.exe at the time of update?  Also is it possible that a file is in use or you have a command prompt open to your Firefox directory?
CruNcher, please see bug 760027 which has been filed earlier today.
You can verify if it's the same by looking in your log at:
C:\ProgramData\Mozilla\logs

In particular if it's the same I think you'll see "Not enough command line arguments to execute a service command" at the end.
(Reporter)

Comment 74

6 years ago
Installing service...
User access was set successfully on the service.
The service was installed successfully

Uninstalling service...
The service was uninstalled successfully

Above is what I have and it did update the re spins and today's update. The only problem is this huge screen that tells you it was updated,if that was cut say to 3x5 it would be great. I have removed the service but have it set to enabled in about:config. Si I can verify that it works.
I'm not sure which screen you mean but it sounds like it is working now, thanks Gary.
(Reporter)

Comment 76

6 years ago
It says upgrade successful and is kind of larger. But I can live with that, Thanks for all of your hard work on this one.

Comment 77

6 years ago
On today's update the behavior was still as described on https://bugzilla.mozilla.org/show_bug.cgi?id=759390#c4

Am I seeing a different bug?

C:\ProgramData\Mozilla\logs does not exists here.

Comment 78

6 years ago
(In reply to Brian R. Bondy [:bbondy] from comment #73)
> You can verify if it's the same by looking in your log at:
> C:\ProgramData\Mozilla\logs
> 
> In particular if it's the same I think you'll see "Not enough command line
> arguments to execute a service command" at the end.

Nope its this 

Disabled unneeded token privilege: SeAssignPrimaryTokenPrivilege.
Disabled unneeded token privilege: SeAuditPrivilege.
Disabled unneeded token privilege: SeBackupPrivilege.
Disabled unneeded token privilege: SeCreateGlobalPrivilege.
Disabled unneeded token privilege: SeCreatePagefilePrivilege.
Disabled unneeded token privilege: SeCreatePermanentPrivilege.
Disabled unneeded token privilege: SeCreateSymbolicLinkPrivilege.
Could not disable token privilege value: SeCreateTokenPrivilege. (1300)
Disabled unneeded token privilege: SeDebugPrivilege.
Could not disable token privilege value: SeEnableDelegationPrivilege. (1300)
Disabled unneeded token privilege: SeImpersonatePrivilege.
Disabled unneeded token privilege: SeIncreaseBasePriorityPrivilege.
Disabled unneeded token privilege: SeIncreaseQuotaPrivilege.
Disabled unneeded token privilege: SeIncreaseWorkingSetPrivilege.
Disabled unneeded token privilege: SeLoadDriverPrivilege.
Disabled unneeded token privilege: SeLockMemoryPrivilege.
Could not disable token privilege value: SeMachineAccountPrivilege. (1300)
Disabled unneeded token privilege: SeManageVolumePrivilege.
Disabled unneeded token privilege: SeProfileSingleProcessPrivilege.
Could not disable token privilege value: SeRelabelPrivilege. (1300)
Could not disable token privilege value: SeRemoteShutdownPrivilege. (1300)
Disabled unneeded token privilege: SeRestorePrivilege.
Disabled unneeded token privilege: SeSecurityPrivilege.
Disabled unneeded token privilege: SeShutdownPrivilege.
Could not disable token privilege value: SeSyncAgentPrivilege. (1300)
Disabled unneeded token privilege: SeSystemEnvironmentPrivilege.
Disabled unneeded token privilege: SeSystemProfilePrivilege.
Disabled unneeded token privilege: SeSystemtimePrivilege.
Disabled unneeded token privilege: SeTakeOwnershipPrivilege.
Disabled unneeded token privilege: SeTcbPrivilege.
Disabled unneeded token privilege: SeTimeZonePrivilege.
Could not disable token privilege value: SeTrustedCredManAccessPrivilege. (1300)
Disabled unneeded token privilege: SeUndockPrivilege.
Could not disable token privilege value: SeUnsolicitedInputPrivilege. (1313)
Executing service command clear-prefetch, ID: ea51fc5e-1102-490b-8e1c-4e3574ead130
Service command not recognized: clear-prefetch.
service command MozillaMaintenance complete with result: Failure.
(Assignee)

Comment 79

6 years ago
(In reply to alex_mayorga from comment #77)
> On today's update the behavior was still as described on
> https://bugzilla.mozilla.org/show_bug.cgi?id=759390#c4
> 
> Am I seeing a different bug?

Yes.  Can you please file another bug?  Thanks!
(Reporter)

Comment 80

6 years ago
To comment 75 This one:

[IMG]http://i20.photobucket.com/albums/b243/TK-1913/update.png[/IMG]
You need to log in before you can comment on or make changes to this bug.