Last Comment Bug 759524 - ASSERTION: aKeyEvent.charCode is modified unexpectedly
: ASSERTION: aKeyEvent.charCode is modified unexpectedly
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Widget: Cocoa (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla15
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
: Markus Stange [:mstange]
Mentors:
Depends on:
Blocks: 758420
  Show dependency treegraph
 
Reported: 2012-05-29 14:52 PDT by Paul O'Shannessy [:zpao] (not reading much bugmail, email directly)
Modified: 2012-05-31 05:54 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.83 KB, patch)
2012-05-29 21:15 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
smichaud: review+
Details | Diff | Splinter Review

Description Paul O'Shannessy [:zpao] (not reading much bugmail, email directly) 2012-05-29 14:52:14 PDT
I'm getting a bunch of assertions when I run a debug build and use a keyboard shortcut.

###!!! ASSERTION: aKeyEvent.charCode is modified unexpectedly: '!computeCharCode || initialCharCode == aKeyEvent.charCode', file /Users/pao/Mozilla/mozilla-central-dev/widget/cocoa/TextInputHandler.mm, line 936

Masayuki, I'm hoping you'll have some idea since you've been touching this code recently.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-29 19:33:03 PDT
Ugh.
Comment 2 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-29 21:15:43 PDT
Created attachment 628207 [details] [diff] [review]
Patch

just a mistake.
Comment 3 Steven Michaud [:smichaud] (Retired) 2012-05-30 08:38:38 PDT
Comment on attachment 628207 [details] [diff] [review]
Patch

Sorry I didn't catch this one myself :-(
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2012-05-30 18:26:38 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/1543ca5ec175

I'm sorry for the mistake.
Comment 5 Ed Morley [:emorley] 2012-05-31 05:54:31 PDT
https://hg.mozilla.org/mozilla-central/rev/1543ca5ec175

Note You need to log in before you can comment on or make changes to this bug.