The default bug view has changed. See this FAQ.

The location of the window needs to be remembered if a user moves it - each app launch should start at the last window location set by the user

VERIFIED FIXED in Firefox 16

Status

Firefox Graveyard
Webapp Runtime
P3
normal
VERIFIED FIXED
5 years ago
a year ago

People

(Reporter: jsmith, Assigned: Felipe)

Tracking

15 Branch
Firefox 16

Details

(Whiteboard: [qa!])

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
User feedback about window management. Testing various apps (e.g. Chrome), if a user decides to move the application around, the location should be remembered somewhere. Upon close and restart of the app, the location of the app should start at the last remembered location.
(Reporter)

Updated

5 years ago
Priority: -- → P3
Target Milestone: --- → Firefox 16
Target Milestone: Firefox 16 → ---
(Assignee)

Updated

5 years ago
Assignee: nobody → felipc
Status: NEW → ASSIGNED
(Assignee)

Updated

5 years ago
Assignee: felipc → nobody
Component: Web Apps → Webapp Runtime
QA Contact: webapps → webapp-runtime
(Assignee)

Comment 1

5 years ago
Created attachment 637351 [details] [diff] [review]
Patch

Simple change, needed to add the persist attribute to the window. Took me a while to figure out that the window also needs to have an id for it to work.
Also setting a starting screenX/Y for first-run at [30,30] which seems better than the [0,0] corner.
Attachment #637351 - Flags: review?(myk)
(Assignee)

Updated

5 years ago
Assignee: nobody → felipc
Comment on attachment 637351 [details] [diff] [review]
Patch

Review of attachment 637351 [details] [diff] [review]:
-----------------------------------------------------------------

D'oh!  An `id`!  So that's why my first attempt to fix this bug failed!

Regarding the initial position of the window, we've previously discussed centering it, as someone (timA?) noted that apps tend to be centered on firstrun (at least on Windows).

Firefox uses 4,4, and 30,30 is reasonable (as are most values), but I think we're better off centering the window by adding `centerscreen` to the list of features in the command line handler's openWindow call.  We can still use `persist="screenX screenY"` to persist any changes the user then makes to its position.
Attachment #637351 - Flags: review?(myk) → review+
(Assignee)

Comment 3

5 years ago
Created attachment 637715 [details] [diff] [review]
Patch v2

Ok cool, since it's a small change let's use this bug to also include centerscreen instead of filing a new one for that. Also removed the 30x30 initial position.
Attachment #637351 - Attachment is obsolete: true
Attachment #637715 - Flags: review?(myk)
Attachment #637715 - Flags: review?(myk) → review+
(Assignee)

Comment 4

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/72a0595d29a1
(Reporter)

Updated

5 years ago
Whiteboard: [qa+]
https://hg.mozilla.org/mozilla-central/rev/72a0595d29a1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
(Reporter)

Comment 6

5 years ago
Verified on inbound 6/30.
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
(Reporter)

Comment 7

5 years ago
Also - note there might be a regression as a result of this patch in bug 769955 - an icon is no longer showing up for the app window.
(Reporter)

Updated

5 years ago
QA Contact: jsmith
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.