X axis omitted when zoomed in 30, 90 and 365 Days sorting of Data.

VERIFIED FIXED in 2012-07-05

Status

Marketplace
Statistics
P5
normal
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: Adi_J, Assigned: ngoke)

Tracking

2012-07-05
Points:
---

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 628241 [details]
Screen shot of the Bug

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:15.0) Gecko/15.0 Firefox/15.0a1
Build ID: 20120527030515

Steps to reproduce:

Steps to reproduce:

1. Go to Mozilla Marketplace App Statistics: example: https://marketplace-dev.allizom.org/en-US/app/evernote-web/statistics/?last=30

2. Click on week or month in the "group by:" 

3. In the "for last:" select either, 30,90 or 365 Days.

4. Make multiple Zooms on the Data.


Actual results:

* In some cases just with a single zoom the x-axis disappears.
* In others multiple zooms make the x-axis disappear. 


Expected results:

The x-axis should still be visible, with the y axis parameters getting consolidated or re-scaled to the new zoom level.
Blocks: 695236
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5
Kevin, is this something we can easily fix?
Assignee: nobody → ngoke
Target Milestone: --- → 2012-06-28
Target Milestone: 2012-06-28 → 2012-07-05
(Assignee)

Comment 2

6 years ago
I had to make a compromise due to a Highcharts issue. There's supposed to be functionality to set a max zoom/min range level so I'm not able zoom down to the hours level, but that option has been and is still broken. Earlier, I just set a fixed tick interval where the xAxis doesn't zoom down with the graph. But since it looks like it's disappearing, I re-enabled the ability to zoom down the the hourly level (though with the day being labeled along with the time). Until Highcharts lets me set a max zoom/min range, we're forced to being able to zoom down to an hourly level for days, daily level for weeks, and daily level for months. But I assume that's better than the xAxis not being able to zoom at all.

https://github.com/mozilla/zamboni/commit/8d2629fd3e812b449be1b025a22745dfa118874e

See if that is better.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

6 years ago
now it looks like the max zoom is responding. some more work on it. https://github.com/mozilla/zamboni/commit/a7fac9438a014721c5e6fbe462d4b9d2191a4605
(Reporter)

Comment 5

6 years ago
Everything seems to work fine, thanks for the fix.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.