The default bug view has changed. See this FAQ.

Intermittent accessible/events/test_docload.xul | Test timed out.

RESOLVED FIXED in mozilla15

Status

()

Core
Disability Access APIs
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: philor, Assigned: surkov)

Tracking

(Blocks: 1 bug, {intermittent-failure})

Trunk
mozilla15
x86
Windows XP
intermittent-failure
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=12184943&tree=Mozilla-Inbound
Rev3 WINNT 5.1 mozilla-inbound opt test mochitest-other on 2012-05-29 22:52:54 PDT for push 2cfe694cbc1a
slave: talos-r3-xp-059

3538 INFO TEST-PASS | chrome://mochitests/content/a11y/accessible/events/test_docload.xul | Focussed ['document node', address: [object XrayWrapper [object HTMLDocument]], role: document, name: 'data:text/html,<html><body><iframe%20src='http://example.com'></iframe></body></html>', address: [xpconnect wrapped nsIAccessible]] must be focusable!

Event type: reorder. Target: ['iframe node', address: [object XrayWrapper [object HTMLIFrameElement]], role: internal frame, address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

Event type: state change. Target: ['toolbarbutton@id="urlbar-reload-button" node', address: [object XULElement], role: pushbutton, name: 'Location', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

Event type: state change. Target: ['toolbarbutton@id="urlbar-reload-button" node', address: [object XULElement], role: pushbutton, name: 'Location', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

Event type: state change. Target: ['toolbarbutton@id="urlbar-reload-button" node', address: [object XULElement], role: pushbutton, name: 'Location', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1

Event type: state change. Target: ['toolbarbutton@id="urlbar-reload-button" node', address: [object XULElement], role: pushbutton, name: 'Location', address: [xpconnect wrapped nsIAccessible]]. Listeners count: 1
3539 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/a11y/accessible/events/test_docload.xul | Test timed out.

(screenshot of a browser window with data:text/html,<html><body><iframe src='http://example.com'></iframe></body></html> loaded in it, and the tiresome Windows Security Center balloon that's over the bottom corner of the window in every WinXP screenshot looking like it might be something but probably being nothing)

540 INFO TEST-END | chrome://mochitests/content/a11y/accessible/events/test_docload.xul | finished in 304549ms
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Comment 5

5 years ago
Alex, could the checkin for bug 754165 have something to do with these intermittent failures? This landed very recently, and this bug appeared shortly after. If it does, and it is determined that bug 754165 is the cause for this random failure, we should back it out again and figure out what's wrong there. I don't want to go something like this into Aurora if it has this many failures in such a short time.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 60

5 years ago
(In reply to Marco Zehe (:MarcoZ) from comment #5)
> Alex, could the checkin for bug 754165 have something to do with these
> intermittent failures?

yes

> This landed very recently, and this bug appeared
> shortly after. If it does, and it is determined that bug 754165 is the cause
> for this random failure, we should back it out again and figure out what's
> wrong there.

I don't agree, the test added by that bug fails

> I don't want to go something like this into Aurora if it has
> this many failures in such a short time.

no evidence that behavior was broken, it's safe for Aurora.
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Updated

5 years ago
Depends on: 760099
(Assignee)

Updated

5 years ago
Blocks: 518190
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Before the uplift, I'm going to either disable this test or backout bug 754165, due to too many failures. I'm presuming you'd prefer the former?
Comment hidden (Treeherder Robot)
(In reply to Ed Morley [:edmorley] from comment #96)
> Before the uplift, I'm going to either disable this test or backout bug
> 754165, due to too many failures. I'm presuming you'd prefer the former?

Generally yes. Trust me, this is heavily on my radar as well. I'll make a final call on this on Monday.
Thank you :-)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 182

5 years ago
Created attachment 629684 [details] [diff] [review]
patch

so, we have a reorder event from Firefox UI that contains a xul:browser (a target of reorder event we wait for), I assume they are coalesced but since no one debug failed and thus no logging enabled then I cannot be sure they are coalesced. Let's disable the test to stop bleeding.
Assignee: nobody → surkov.alexander
Status: NEW → ASSIGNED
Attachment #629684 - Flags: review?(trev.saunders)
Attachment #629684 - Flags: review?(trev.saunders) → review+
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 185

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/cfee4e39759d
Target Milestone: --- → mozilla15
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
https://hg.mozilla.org/mozilla-central/rev/cfee4e39759d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 766112
(Reporter)

Updated

5 years ago
Blocks: 795210
Keywords: intermittent-failure
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.