Mouse key up event not detected by mozilla after the scroll bar is used

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
7 years ago
3 years ago

People

(Reporter: rahul.bana, Unassigned)

Tracking

11 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Build ID: 20120312181643

Steps to reproduce:

In my web application, there is a scrollable div.
The items within the div are dragged and dropped using the mouse key.
On mouse down draggable, the item gets attached to the mouse cursor movement and when the mouse key is released (mouse up event), the item gets released from the mouse control.
This functionality works fine unless I scroll the div by clicking and dragging on the scroll bar.
 



Actual results:

1. Using mouse, I clicked and dragged the scrollable div
2. Mousedown and dragged the item(image) in the div
3. Released the mouse (mouseup) 
4. The item still attached to the mouse cursor.


Expected results:

1. Using mouse, I clicked and dragged the scrollable div
2. Mousedown and dragged the item in the div
3. Released the mouse (mouseup) 
4. The item should get detached from the mouse movement.
Hello,

I just found your bug from 2012 and saw that there was no update until now...
can you please attach an example code to this report?
this will help the developers to go forward with this problem

thanks for your help
Flags: needinfo?(rahul.bana)
Closed -> no feedback from reporter.

please feel free to reopen this report if you have new or additional information.
thank you for your help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(rahul.bana)
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

4 years ago
Created attachment 8526686 [details]
Code and snapshot of the problem.

Zip contains js files and problem snapshot.
(Reporter)

Updated

4 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 4

4 years ago
Hello,

I have added the code and snapshot of the problem.
Please let me know in case further information is required from my end.


Regards
Hello Rahul,

can you upload a full html example?
I just tried to create a little page and it is not easy to use your js files :-(

thank you again
Hi,

Is this issue still reproducible on the latest Firefox release(43.0.4) ? If yes, can you please provide a simplified testcase where this issue can be observed so that I can test this on my end?

When trying to reproduce the issue please use a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Cipri
Flags: needinfo?(rahul.bana)
Since the reporter didn't provide the requested information, I will mark this issue as RESOLVED INCOMPLETE. If you still encounter this problem, please feel free to reopen this bug, or file a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago3 years ago
Flags: needinfo?(rahul.bana)
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.