dialog checkmarks are always black (invisible with background)

VERIFIED WONTFIX

Status

SeaMonkey
Themes
--
minor
VERIFIED WONTFIX
17 years ago
10 years ago

People

(Reporter: mstecyk, Assigned: Joe Hewitt (gone))

Tracking

({polish})

Trunk
x86
Windows 98
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
the checkmarks need to use a system color instead.

Comment 1

17 years ago
-> themes
Assignee: blakeross → hewitt
Component: XP Apps: GUI Features → Themes
QA Contact: sairuh → pmac
Summary: dialog checkmarks are always black (invisible with blackground) → dialog checkmarks are always black (invisible with background)
The checkmarks are actually images... so making them use a system color is 
probably somewhat difficult.  Does the theme you are using not define a color for 
the background?
(Reporter)

Comment 3

17 years ago
If the checkmark is an image then it shouldn't have a transparent background;
that will solve the problem.  The alternative is to implement it the Microsoft
way using fonts, which solves the color control problem.  Either solution seems
acceptable.

Comment 4

17 years ago
Marking NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: polish, ui
(Assignee)

Comment 5

17 years ago
Can't fix this with the resources we have today.  the checkbox is a black image
- we don't have the ability to install special fonts, and we don't have SVG, so
we're stuck with the black image for now.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
*** Bug 84597 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
According to Joe, this bug markes as 'wonfix'.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 8

17 years ago
i will mention explicitly here that this only occurs with the classic theme; the
modern theme uses bitmaps for all states and thus eliminates the problem.  if
its too hard to change the theme to use the font instead of the bitmap to
indicate state, then perhaps you could change the display of the box/circle to
use a white background instead of the system window color.  how is that part
generated?

Comment 9

17 years ago
*** Bug 113791 has been marked as a duplicate of this bug. ***

Comment 10

16 years ago
*** Bug 147300 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
this is also the issue in bug 69434 (two dups)
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.