Mac OS X 10.5 crash ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey | nsMsgDatabase::CreateCollationKey

RESOLVED WORKSFORME

Status

Thunderbird
Folder and Message Lists
--
critical
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: maps.paperkey, Unassigned)

Tracking

({crash})

12 Branch
Thunderbird 12.0
x86
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [workaround: comment 6], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 628361 [details]
Crash report

Thunderbird crashes everytime I click on the main 'Sent' folder, yet not on the individual sub-folders within it (I can access the content of the sub-foders). I have compacgted TB, tried 'Safe' restarts and checked the add-ons (extensions & plug-ins - all up to date) but still have the same problem. I have about 2500 e-mails in the main 'Sent' folder(not including the sub-folders within it) which I want to sort and drag to their appropriate sub-folders. This problem occurs only on that folder. Everything else works fine.

The crash report attachment is only the main part. (I am new at this so not sure what is required or what to do)

Comment 1

6 years ago
my comment in bug 668978  " #2 crash for Macs all the thunderbird crashes are OS X 10.5, and a high percentage are startup.  like Bug 593132 - Mac crash sorting on subject or on startup"

However, NOT all ucol_setVariableTop crashes (perhaps not even most) involve nsMsgDatabase::CreateCollationKey

bp-5e913280-81b2-4d34-a527-454932120524

0	libSystem.B.dylib	szone_free	
1	libSystem.B.dylib	free	
2	libicucore.A.dylib	ucol_setVariableTop	
3	libicucore.A.dylib	ucol_getSortKey	
4	CarbonCore	UCGetCollationKey	
5	XUL	nsCollationMacUC::AllocateRawSortKey	intl/locale/src/mac/nsCollationMacUC.cpp:179
6	XUL	nsMsgDatabase::CreateCollationKey	mailnews/db/msgdb/src/nsMsgDatabase.cpp:3660
7	XUL	nsMsgDatabase::RowCellColumnToCollationKey	mailnews/db/msgdb/src/nsMsgDatabase.cpp:3633
8	XUL	nsMsgHdr::GetSubjectCollationKey	mailnews/db/msgdb/src/nsMsgHdr.cpp:726
9	XUL	nsMsgDBView::GetCollationKey	mailnews/base/src/nsMsgDBView.cpp:4178
10	XUL	nsMsgDBView::Sort	mailnews/base/src/nsMsgDBView.cpp:4516
Severity: normal → critical
Status: UNCONFIRMED → NEW
Crash Signature: [@ szone_free | free | ucol_setVariableTop] [@ ucol_setVariableTop ]
Ever confirmed: true
Keywords: crash
Summary: Folder crash → Mac crash ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey | nsMsgDatabase::CreateCollationKey

Comment 2

6 years ago
Looks like the OS/X collation key stuff is broken again. I thought they had ported the fix to 10.5 but maybe not. In any case, there's not much we can do about it. You can delete the Sent.msf file from your user profile directory. That will cause us to rebuild it, w/o the folder sorted by the subject column, which is what's causing your crash. So once it stops crashing, you're going to want to stop sorting by subject (or upgrade to a newer version of OS/X.

Comment 3

6 years ago
Getting a fix from Apple took about a year last time, and I doubt they're supporting 10.5 anymore.

Comment 4

6 years ago
Indeed, all crashes are OS X 10.5
Summary: Mac crash ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey | nsMsgDatabase::CreateCollationKey → Mac OS X 10.5 crash ucol_setVariableTop | ucol_getSortKey | UCGetCollationKey | nsMsgDatabase::CreateCollationKey
(Reporter)

Comment 5

6 years ago
Hi Biennenu,

(I am not sure how these bug threads work). Thanks for the comments. I have been out of action for a while so am getting back to that issue only now.

OS: I am stuck for the time being with OS 10.5.8 as it's the only OS version that will work with the older software I need to open, import and reformat legacy files that represent YEARS of work. (I had sarted with Snow Leopard but had to downgrade to Leopard). Until then, I don't have much choice.

What puzzles me is that all the other folders and subfolders work fine: just that one enveloping 'Sent' folder, whilst I can access all the subfolders within it fine... And Thunderbird crashes ONLY when I click on that main folder name, not when I click on its subfolders. And not either on start up of Thunderbird. it's very specific and predictable.

Is there anyway I can access the content in that main ('envelope') folder?

I can't work without folders and sub-folders: too many e-mails about too many different subjects.

I was wondering if the problem was not linked to too many e-mails? I have been better at sorting my incoming e-mails in folders than the outgoing ones which tended to all pile up into that one main 'Sent' folder.

I would apprecaite your comment on that.

Regards

Patrick

Comment 6

6 years ago
It's a particular message or messages in your Sent folder with a subject that's crashing the Mac OSX 10.5.8 sorting code. To get around this,you need to delete the Sent.msf file (not the Sent file w/ no extension, which contains your messages but the database associated with it, which is named Sent.msf), restart TB, and don't sort by subject on that folder again.

Help menu, trouble shooting information will help you figure out where on disk the particular Sent.msf file is. You need to delete it, because it's the file that remembers you were sorted by subject.

Comment 7

3 years ago
According to crash-stats, this crash is gone starting in version 17.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
Whiteboard: [workaround: comment 6]
You need to log in before you can comment on or make changes to this bug.