Last Comment Bug 760011 - Make nsIMozSmsRequest inherit from nsIDOMDOMRequest
: Make nsIMozSmsRequest inherit from nsIDOMDOMRequest
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla16
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: 708546
Blocks: 749086
  Show dependency treegraph
 
Reported: 2012-05-31 01:39 PDT by Mounir Lamouri (:mounir)
Modified: 2012-09-30 02:28 PDT (History)
3 users (show)
ryanvm: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (2.77 KB, patch)
2012-05-31 01:39 PDT, Mounir Lamouri (:mounir)
jonas: review+
mounir: checkin+
Details | Diff | Review

Description Mounir Lamouri (:mounir) 2012-05-31 01:39:18 PDT
Created attachment 628624 [details] [diff] [review]
Patch v1

So we are sure to share the same interface and be recognized as sharing it (|request instanceof DOMRequest| would return true). It seems to be a good compromise compared to the highly time consuming and risky work happening in bug 749086.
Comment 1 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-08 15:37:05 PDT
Comment on attachment 628624 [details] [diff] [review]
Patch v1

Review of attachment 628624 [details] [diff] [review]:
-----------------------------------------------------------------

This seems fine, but is there a reason to keep the SmsRequest interface at all?
Comment 2 Mounir Lamouri (:mounir) 2012-06-09 03:35:23 PDT
(In reply to Jonas Sicking (:sicking) Vacation June 11-22 from comment #1)
> Comment on attachment 628624 [details] [diff] [review]
> Patch v1
> 
> Review of attachment 628624 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> This seems fine, but is there a reason to keep the SmsRequest interface at
> all?

Getting ride of nsIDOMSmsRequest isn't a trival work. We have a bug for that but having nsIDOMSmsRequest inheriting from nsIDOMDOMRequest is a good middle ground. I wonder how important that would be to remove nsIDOMSmsRequest for v1 knowing those changes will need to be backed and might create regressions.
Comment 3 Jonas Sicking (:sicking) PTO Until July 5th 2012-06-09 07:59:54 PDT
It's definitely not important. I just figured a search'n'replace would work, but if there's non-trivial work involved here I agree we should punt.
Comment 4 Ryan VanderMeulen [:RyanVM] 2012-06-09 19:35:18 PDT
https://hg.mozilla.org/mozilla-central/rev/5a489379b537

Note You need to log in before you can comment on or make changes to this bug.