crash in @nsScreenAndroid::ApplyMinimumBrightness with onmozorientationchange

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: martijn.martijn, Unassigned)

Tracking

({crash, mobile, testcase})

Trunk
ARM
Android
crash, mobile, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], crash signature)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 628649 [details]
testcase

I reproduced this in current trunk build on the Samsung Galaxy Nexus.

Steps to reproduce:
- Visit testcase
- Tap on the "open win and close onmozorientationchange" button 5 times
- Tap on the Android back button
- Change the orientation of your phone from portrait to landscape of vice versa.


This bug was filed from the Socorro interface and is 
report bp-8e0a09f5-af60-479d-adf0-69f0f2120531 .
============================================================= 
0 		@0x0 	
1 	libxul.so 	nsScreenAndroid::ApplyMinimumBrightness 	widget/android/nsScreenManagerAndroid.cpp:63
2 		@0x5cfae7ee 	
3 	libdvm.so 	libdvm.so@0x33b42 	
4 	dalvik-heap (deleted) 	dalvik-heap @0xc61016 	
5 	libdvm.so 	libdvm.so@0xb2f8e 	
6 	dalvik-heap (deleted) 	dalvik-heap @0x936 	
7 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x29ee96 	
8 	libdvm.so 	libdvm.so@0x4f8e7 	
9 	dalvik-heap (deleted) 	dalvik-heap @0xdb3006 	
10 	libdvm.so 	libdvm.so@0x94f04 	
11 	dalvik-heap (deleted) 	dalvik-heap @0xc7393e 	
12 	dalvik-heap (deleted) 	dalvik-heap @0xdb2fe6 	
13 	data@app@org.mozilla.fennec-1.apk@classes.dex 	data@app@org.mozilla.fennec-1.apk@classes.dex@0x904eb 	
14 	dalvik-heap (deleted) 	dalvik-heap @0xdb2ffe 	
15 	libdvm.so 	libdvm.so@0x30c2e 	
16 	libdvm.so 	libdvm.so@0xb2f8e 	
17 	dalvik-LinearAlloc (deleted) 	dalvik-LinearAlloc @0x29ee96 	
18 	libdvm.so 	libdvm.so@0x34272 	
19 	dalvik-heap (deleted) 	dalvik-heap @0x2ebdffe 	
20 	dalvik-heap (deleted) 	dalvik-heap @0x333dffe
(Reporter)

Comment 1

7 years ago
Hrm, I can't seem to reproduce now with the str in comment 0. But I can still reproduce it occasionally when switching orientation, opening and closing multiple windows and closing the corresponding alerts. The crash does not happen reliably, it seems, though.

Updated

7 years ago
Hardware: All → ARM
Whiteboard: [native-crash]
(Reporter)

Comment 2

3 years ago
I can't reproduce this crash anymore on the Galaxy Nexus.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.