Closed Bug 760215 Opened 10 years ago Closed 10 years ago

Move premium apps back to incomplete status if their PayPal information is missing

Categories

(Marketplace Graveyard :: Payments/Refunds, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: krupa.mozbugs, Unassigned)

References

()

Details

(Whiteboard: [dupeme][ye-olde-paypal])

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/en-US/app/test-app-abc/
2. Try to purchase the app


actual behavior:
App purchase fails since the PayPal ID is empty for this app.

May 31 10:46:50 dev1.addons.phx1.mozilla.com: [29b297a8-858f-11e1-a22e-441ea15c11a8][76.21.94.186] z.paypal:ERROR Paypal Error (580022): Invalid request parameter: email cannot be blank :/data/www/addons-dev.allizom.org/zamboni/apps/paypal/__init__.py:514

expected behavior:
If a public app loses its PayPal info, we should move it back to incomplete status.
Do we know how it came to be empty?
I think the STR is to create a free app. This does not need a paypal id. Then change the app to premium, nothing sends you to the manage paypal page to set up your paypal account.

You shouldn't be able to change to premium until the paypal account is correctly configured.
Priority: -- → P2
Assignee: nobody → amckay
Target Milestone: --- → 2012-06-14
Blocks: 766201
No longer blocks: 752013
Target Milestone: 2012-06-14 → ---
Blocks: 766199
Assignee: amckay → nobody
Priority: P2 → --
No longer blocks: 766199
Whiteboard: [dupeme] → [dupeme][ye-olde-paypal]
old system
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.