[mozillalabs] Add a cron command to dev instance

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: pmac, Assigned: bburton)

Tracking

Details

(URL)

Also have a settings change.

Need to add the following command to run daily:

python manage.py cron delete_abandoned_profiles

Also need the CACHES['default']['BACKEND'] setting in settings_local.py set to match the new value in settings_local.py-dist. For convenience, the new value is:

'caching.backends.memcached.CacheClass'

There is also a database migration that should have happened. I'm assuming since dev is still up that it was successful. Could you confirm for me that migrations are indeed run on deploy?
(Assignee)

Updated

6 years ago
Assignee: server-ops → bburton
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 1

6 years ago
1. We do run syncdb and migrate each time we deploy

    echo -e "syncdb"
    python $CODE_DIR/manage.py syncdb &> /dev/null
    checkretval

    echo -e "migrate"
    python $CODE_DIR/manage.py migrate &> /dev/null
    checkretval

2. I'll add the settings and the cron job on dev shortly
(Assignee)

Comment 2

6 years ago
I've added to -dev, it'll run at 00:30 each day

30 0 * * * root python /data/genericrhel6-dev/src/mozillalabs-dev.allizom.org/betafarm/manage.py cron delete_abandoned_profiles &> /dev/null

I've pushed the config change live on dev and I confirmed I was able to login
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.