Shouldn't be able to have duplicate server names.

RESOLVED INVALID

Status

RESOLVED INVALID
18 years ago
7 years ago

People

(Reporter: stephend, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Halloween2011Bug], URL)

Build ID: 2001041304, Mac, Win32 and Linux.

Note: This is from running my Functional Tests. If this is correct behavior, let 
me know. *4.x only adds existing news servers to the same profile, so I can't 
say, "4xp"*

Summary: Shouldn't be able to have duplicate server names.

Steps to Reproduce:

1. Add a server, news.mozilla.org to the Account Manager.
2. Subscribe to a group.
3. Go back to the Account Manager, New Account.
4. Change either your e-mail address or username, and notice that you can now:
5. Add the same server, news.mozilla.org to the Account Manager.

Expected Results:

"A mail or newsgroup account with the same user name and server name already 
exists..."

Actual Results:

The Account Wizard lets us add as many servers of the same type and name, as 
long as we vary the username or e-mail address.

If this is by design, please don't hesitate to mark this invalid.  It's in my 
functional testing under Misc Server Conditions.

Updated

18 years ago
QA Contact: esther → nbaca
I think a fix for this will be included with cavin's fix for #14295

Comment 2

17 years ago
I agree. Bug 14295 will fix this as well. Adding dependency.
Depends on: 14295

Comment 3

17 years ago
Stephend, does the expected behaviour occur now?
No, this still happens.  I have to wonder what our actual desired behavior is, now.

Comment 5

17 years ago
Ok, I reproduced this by adding two news accounts with the same account name 
and the same server address.

This is definitely a bug that should be addressed. Moving to Account Manager 
though, since they control the error checking that's supposed to happen but 
obviously doesn't.

I'm sort of wondering if all hell will break loose if you mess around with two 
accounts with the same type/address/name. How does our internal files (i.e. 
prefs.js etc.) handle this?

Upgrading severity and nominating.
Assignee: sspitzer → racham
Component: Networking - News → Account Manager
Keywords: mozilla0.9.7
Keywords: mozilla0.9.7

Comment 6

16 years ago
I __WANT__ to be able to create two accounts with the same username and server.
It's not a bug, and it should ALWAYS be allowed. At most warn that it's
happened, never forbid it. 

I want to be able to do this so that I can create multiple IMAP accounts that
access the same server as the same user, but are configured to read their mbox
out of different subdirectories on the server, and use a different email addresses.

I was coming here to file a bug that I was getting this error and that I should
be allowed to do this--just because you can't imagine why I would want to do
this doesn't mean you should forbid it. I can imagine very well why I want to do
this, and was utterly amazed that Mozilla would arbitrarily forbid it.
I agree -- we can put up a warning dialog or something, though I'm not sure what
the risk is for having a duplicate account, but we shouldn't forbid it.  (Justin
_really_ wants a Mutt-style folder-hook, I think, but this seems like something
that we should permit as well.)
mass re-assign.
Assignee: racham → sspitzer
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
QA Contact: nbaca

Comment 9

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 10

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 11

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 12

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 13

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED
Actually, you should be able to have several accounts for the same server, although probably not with the *exact* same combination of server/login/encryption/etc. settings.
Assignee: mail → nobody
QA Contact: mailnews-account
Resolution: EXPIRED → INVALID
Whiteboard: [Halloween2011Bug]
You need to log in before you can comment on or make changes to this bug.