Closed Bug 760739 Opened 8 years ago Closed 8 years ago

could we make FINALIZE_*_BACKGROUND work in the shell?

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 763800

People

(Reporter: luke, Unassigned)

Details

For like the third time now I have foolishly specified using a FINALIZE_*_BACKGROUND FinalizeKind in shell builds (where !defined(JS_THREADSAFE) and hence there is no background finalization).  Instead of asserting, this bug manifests itself in random crashes in GC.

Perhaps we could either:
 1. catch this bug eagerly with an assert, or
 2. make _BACKGROUND finalize kinds work in the shell so that we we could take out these #ifdef JS_THREADSAFEs (e.g., JSFunction and the various ScopeObjects)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 763800
You need to log in before you can comment on or make changes to this bug.